Subject: mpiJava from NPAC

From: Mark Baker <[email-masked]>
Date: Wed, 5 Aug 98 20:16:24 +0000

Dear all,

A discussion started a week or two back about the various message passing methodologies 
that could currently be used with Java for parallel and distributed applications.

I'd like to draw your attention to the work that we've been doing at NPAC to design, 
develop and implement an object-based Java interface to MPI. Our mpiJava API is 
modelled as closely as practical on the C++ binding defined in the MPI 2.0 standard 
(currently we only support the MPI 1.1 subset). 

We have successfully built and run mpiJava on a number of platforms and MPI environments, 
including Solaris/MPICH, IRIX/MPICH, NT/WMPI. 

I have set up some Web pages at http://www.npac.syr.edu/projects/pcrc/mpiJava/
where you can find out further details about the interface. We intend to actually
release the software officially early next week when we've had a chance to complete
the release documentation.

We would welcome feedback from the community as to the pros and cons of our Java interface
to MPI.

Mark

-------------------------------------
Dr Mark Baker
CSM, University of Portsmouth, Hants, UK
Tel: +44 1705 844285	Fax: +44 1705 844006
E-mail: [email-masked]
Date: 08/05/98 - Time: 20:16:24
URL http://www.dcs.port.ac.uk/~mab/
-------------------------------------

---

From: Mark Baker <[email-masked]>
Date: Mon, 31 Aug 98 13:59:59 +0000

Dear all,

I'd like to inform you that mpiJava from NPAC is now available....

The mpiJava Web pages are at http://www.npac.syr.edu/projects/pcrc/mpiJava/

We would welcome feedback from the community as to the pros and cons of our Java 
interface to MPI.

Mark

Date: 08/31/98 - Time: 14:00:01

---

From: Mark Baker <[email-masked]>
Date: Mon, 31 Aug 98 13:59:59 +0000

Dear all,

Mark

---

From: [email-masked] (Omer F Rana)
Date: Wed, 19 Aug 1998 19:06:26 +0100 (BST)

Hi,

Details of the programme for the 'Java for High Performance
Network Computing' workshop are attached below. 

Please note that you need to register for
EuroPar to attend, so please do so immediately if you have not
done already. You can register via the web page from:

	http://www.cs.cf.ac.uk/hpjworkshop/

There is also a social programme for September 2, more details
of which can be obtained from the EuroPar website.

If you have any questions, then please do not hesitate to
contact me. I look forward to meeting you at EuroPar.

regards
Omer

PS: Special thanks to Vladimir Getov, David Walker, Jean-Louis Pazat
	 and the EuroPar conference organisers for accomodating us.

PPS: The above web site will be updated with the new schedule in
	a day or so.

	==========================================================

                Java for High Performance
                Network Computing Workshop

                Within EuroPar 1998
                September 2,3 1998

                http://www.cs.cf.ac.uk/hpjworkshop/

The Bolderwood Conference Centre, University of Southampton
===========================================================
This workshop is partially sponsored by JTAP, EuroTools and
IEE Informatics.

2 September 1998 (afternoon).   Lecture Room 5
=============================   ==============

Session 1. Invited Talks
           Chair: David W. Walker
                  (Department of Computer Science,
                   University of Wales, Cardiff, UK)
           Location: Lecture Room 5

13:30  David W. Walker
       Welcome

13:35  JavaGrande and High Performance Java in the US
       Geoffrey Fox
       (NPAC, Syracuse University, Syracuse New York USA)

14:05  HPC Java Efforts at Sun Microsystems
       Siamak Hassanzadeh
       (High Performance Computing, Sun Microsystems,
        Mountain View, California, USA)

14:35  The ActiveJava Framework
       George Thiruvathukal
       (Loyola University, Chicago, Illinois
        and the Java and High-Performance
        Computing Organization, USA)

15:00  Coffee

Session 2. Visualization and Multimedia
           Chair: Vladimir Getov
                  (School of Computer Science,
                   University of Westminster, London, UK)
           Location: Lecture Room 5

15:30  Parallel Java for the Hitachi SR2201
       H. W. Yau (invited talk)
       (EPCC, University of Edinburgh, Scotland, UK)

16:00  Java Performance for Multimedia Applications
       R. Akester, D. Terzis, J. Crowcroft, V. Hardman and
       S. Hailes
       (Department of Computer Science, University College London,
        London, UK)

16:30  SV2: the Collaborative Scientific Data Visualization Tool
       B. Ki and S. Klasky
       (NPAC, Syracuse University, Syracuse USA)

17:00  Break

Session 3. Network Computing
           Chair: Jean-Louis Pazat
                  EuroTools, INRIA, France
           Location: Lecture Room 5

17:10  U-Net/SLE: A Java-based User-Customizable Virtual Network Interface
       M. Welsh and D. Oppenheimer
       (Computer Science Division, University of California, Berkeley, USA)

17:35  Locality Optimization in JavaParty by Means of Static Type
       Analysis
       M. Philippsen and B. Haumacher
       (University of Karlsruhe, Germany)

18:00  Speculative Parallel Execution on JVM
       K. Yoshizoe, T. Matsumoto and K. Hiraki
       (Hiraki Lab, Department of Information Science,
        University of Tokyo, Japan)

18:25  End

3 September 1998 (morning).  Lecture Theatre 4
===========================  =================

Session 4. Invited Talks
           Chair: Giacomo Picenelli (** subject to confirmation **)
                  (Hewlett Packard Labs, Bristol, UK)
           Location: Lecture Theatre 4

 9:00  Multi-Language Programming Environments for High Performance
       Java Computing
       Vladimir Getov
       (School of Computer Science,
        University of Westminster, London, UK)

 9:30  Java based Mobile Agents for Parallel Computing
       Omer Rana
       (Department of Computer Science, University of Wales,
        Cardiff, UK)

10:00  Closing the Performance Gap between Java and 
       Fortran in Technical Computing
       Jose Moreira
       (IBM T. J. Watson Research Center,
        New York, USA)

10:30  Coffee

Session 5. Applications
           Chair: Donald Fisk 
                  (BT Labs, Martlesham, Ipswich UK)
           Location: Lecture Theatre 4

11:00  Java for Controlling and Configuring a Distributed
       Turbine Simulation System
       T. Breitfeld and S. Kolibal,
       (GMD, Sankt Augustin, Germany)
       A. Schreiber and M. Wagner
       (DLR, Cologne, Germany)

11:30  Java-based Coupling for Parallel Predictive-Adaptive
       Domain Decomposition
       C. Germain-Renaud and V. Neri
       (Laboratoire de Recherche en Informatique,
        CNRS - Universite Paris-Sud, France)

12:00  Java for a User-Oriented Transport Parallel Image
       Processing Framework
       Z. Juhasz (Department of Information System, University of 
                  Veszprem, Hungry)
       D. Crookes (Department of Computer Science, Queen's University
                  of Belfast, UK) and
       A. Chaudry (Department of Computer Science, University of 
                  Exeter, UK)

12:30  Lunch

13:30  No scheduled talks

15:00  Coffee

3 September 1998 (afternoon).   Lecture Room 5
=============================   ==============

Session 6. Aspects of Distributed Computing
           Chair: Omer Rana
                  (Department of Computer Science,
                   University of Wales, Cardiff, UK)
           Location: Lecture Room 5

15:30  The Cost of Being Object-Oriented: A Preliminary Study
       Z. Budimlic, K. Kennedy and J. Piper
       (Center for Research on Parallel Computation,
        Rice University, USA)

16:00  Aspects of Portability and Distributed Execution for
       JNI Wrapped Code
       P. A. Gray, V. S. Sunderam
       (Department of Mathematics and Computer Science,
        Emory University, Atlanta GA, USA)
       and V. Getov
       (School of Computer Science, University of Westminster,
        London UK)

16:30  The Do! Project: Distributed Programming Using Java
       P. Launay and J-L Pazat
       (IRISA, Campus de Beaulieu, France)

17:00  Break

Session 7. Java Interfaces to MPI
           Chair: Vladimir Getov
                  (School of Computer Science,
                   University of Westminster, London, UK)
           Location: Lecture Room 5

17:10  Jmpi and a Performance Instrumentation Analysis and
       Visualization Tool for jmpi
       K. Dincer and K. Ozbas
       (Department of Computer Engineering,
        Baskent University, Ankara, Turkey)

17:40  mpiJava: a Java MPI Interface
       M. Baker,
       (University of Portsmouth, Southsea, Hants, UK)
       B. Carpenter, G. Fox, S. H. Ko and X. Li
       (NPAC, Syracuse University, Syracuse, USA)

18:10  End of workshop