Subject: RE: inner class

From: "George K. Thiruvathukal" <[email-masked]>
Date: Thu, 23 Jul 1998 10:34:40 -0500

Hye-Seon:

For more information on the details of inner classes, I would recommend
getting the "Java in a Nutshell" book from O'Reilly and Associates. There
are a few different types of inner classes, but a naive definition of an
inner class is "a class with nested scope." Java also supports the notion of
an anonymous class, which is particularly useful for AWT programming.

George

----------------------------------------------------------------
 George K. Thiruvathukal
 Loyola University of Chicago
 Department of Mathematical and Computer Sciences
 http://www.math.luc.edu

 Please visit http://www.jhpc.org/george for more information.
----------------------------------------------------------------

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of ¸ÍÇý¼±
> Sent: Thursday, July 23, 1998 10:18 PM
> To: [email-masked]'
> Subject: inner class
>
>
> Do you know what inner class is?
> I read it in "Inside the Java Virtual Machine" but I can not understand
> what it is.
> please let me know it.
>
> Thanks in advance
>
> Hye-Seon Maeng
>
>

---

From: Corky Cartwright <[email-masked]>
Date: Thu, 23 Jul 1998 13:55:22 -0500 (CDT)

The description of inner classes on the JavaSoft webpage 

http://java.sun.com/products/jdk/1.1/docs/guide/innerclasses/spec/innerclasses.doc.html

is reasonably clear.  

Static inner classes are straightforward.  Dynamic (non static)
inner classes are more complex because every instance of a
dynamic inner class must have an enclosing instance of the
outer containing class.  

-- Corky Cartwright