Subject: Combinatorial Optimization

From: Saleh Elmohamed <[email-masked]>
Date: Mon, 1 Jun 1998 15:56:05 -0400 (EDT)

Hi Lex,

As I recall about three years or so ago I emailed you about
your book 'A Course in Combinatorial Optimization'. I think
you may have sent me a copy at that time since I seem to 
have one dated 1995.

I'd appreciate it if you could point me to the current version
of that book. I really found it quite useful in my investigations into 
various algorithmic and heuristic approaches to scheduling, and particularly 
timetabling.

Also, would be interested in any recent work (reports, preprints, etc.)
of yours or your group on approximation algorithms or heuristics for 
timetabling.

Best regards,
Saleh

---

From: Alexander Schrijver <[email-masked]>
Date: Mon, 01 Jun 1998 22:22:25 +0200

Dear Saleh,
I don't have a current version yet of my book.
Unfortunately, we never wrote down or work we did for
Dutch Rail on making their timetable, so also in that
I cannot you offer you anything now.
Hopefully soon I have revised the book and can send you
a ps-file.
Best wishes,
Lex

---

From: Saleh Elmohamed <[email-masked]>
Date: Sun, 23 May 1999 19:38:10 -0400

Hi Lex,

I guess I do tend to keep old emails around just in case :-)

I've been trying to encode an instance of a university timetabling
in terms of an instance of a network flows since there
are quite efficient algorithms (e.g. Goldberg at el.)
for the latter. Well, it can be quite restricted, though, and 
for any *reasonably* large size of a timetabling instance one would
end up with a rather large graph. So with all, or most of, the 
constraints that need to be handled, I don't see an easy way to
attain scalability in this case.

Any pointers or suggestions on this or anything related are quite
appreciated.
Perhaps, you may have dealt with something like that
during the course of your work with the Dutch Rail ...
Would really like to hear about it.

Many thanks.

Best wishes,
Saleh