Subject: Re: synchronization methods..

From: Dongmin Kim <[email-masked]>
Date: Tue, 23 Nov 1999 22:35:21 -0500 (EST)

So your algorithm is conbining time and iteration, and
if the client doesn't response in time limit, inform that client
as in proc3 group so that it just do the computation.
Am I right?
If it is right, it makes sense.

Dongmin

On Tue, 23 Nov 1999, Saleh Elmohamed wrote:

> Hi Dongmin,
> 
> I think we can slightly modify the instructions of
> the original algorithm of Geoffrey and I and convert 
> it to the second algorithm we talked about today, the one
> that will guarantee a pause...
> 
> I think if we only set iteration_num to 1 and forget
> about the interval_time_limit we can make it to 
> iterate between master and clients every single step...
> and there will be some sort of waiting for all to
> respond before going on to the next step, and so for.
> 
> Proc1 to represent the master and proc2 the clients. 
> We could ignore proc3 which will be for those 
> clients that just joined in.....
> 
> We also may have to ignore some of the time intervals
> there.
> 
> Ok, what do you think?
> I included it as an attachment.
> 
> I don't want to send him something that is probably
> not too clear.
> 
> -Saleh
> 
> 
> 
>

---

From: Dongmin Kim <[email-masked]>
Date: Tue, 23 Nov 1999 22:40:29 -0500 (EST)

Also how about this?

Use % of response clients as well as time limit.

Which means, if there are 50 clients, and only 10 clients(20%) respond
in the time limit, the master wait until the percentage of the response
client = 80%.
This guarantees in the case of the most clients are much slower than the
master.
Master wait for the time limit and if the time limit is passed, but
the most of the clients does not respond yet, the master still wait for
certain % of the client to respond.

Dongmin