Subject: Re: Secure Shell

From: Mark Natoli <[email-masked]>
Date: Tue, 8 Sep 1998 15:49:09 -0400 (EDT)

Saleh,

  There should be a file in your account ~/.ssh/known_hosts which contains
the "host key" of hosts you have connected to.  Is this file there?

Mark

On Tue, 8 Sep 1998, Saleh Elmohamed wrote:

> >From 'cairo' to anywhere else it comes back with a 'host added
> message and then ask for the password'.
> >From the ospreys or kopernik or the O2 it just prompt for
> the password.
> 
> 
> On Tue, 8 Sep 1998, Mark Natoli wrote:
> 
> > On Tue, 8 Sep 1998, Saleh Elmohamed wrote:
> > 
> > > Hi,
> > > 
> > > I noticed that ssh is not functioning properly. 
> > > 
> > 
> > 
> >   From which hosts are you connecting from and to.
> > 
> > 
> > Mark
> > 
> > 
>

---

From: Mark Natoli <[email-masked]>
Date: Tue, 8 Sep 1998 15:56:14 -0400 (EDT)

On Tue, 8 Sep 1998, Saleh Elmohamed wrote:

> Mark,
> 
> Yes, it is there. The format of the last entry is:
> 
> osprey4 1024 33 90565...large number...

  Is this a big file?  Does it have names of hosts that you haven't
connected to lately?

Mark

---

From: Mark Natoli <[email-masked]>
Date: Tue, 8 Sep 1998 16:13:34 -0400 (EDT)

On Tue, 8 Sep 1998, Saleh Elmohamed wrote:

> It is quite small, only 7 entries. All of them tried to connect to.
> 
> I thought it suppose to have more entries.

   Is your home directory is otherwise in good shape?  If it is, then you
should just put up with the inconvience of replying "yes" when connecting. 

Mark

---

From: Mark Natoli <[email-masked]>
Date: Tue, 8 Sep 1998 16:38:26 -0400 (EDT)

On Tue, 8 Sep 1998, Saleh Elmohamed wrote:

> Yes, home directory seems to be ok. You mean everytimes ssh is invoked I 
> need to type in the password? But that wasn't the case before and I think
> one of the purposes of ssh is to get the use connected to the desired host
> without requiring to type in their passwords.

  The known_hosts file controls whether or not you are asked "You have
never connectedd here, do you wish to accept key (y/n)?"  (or something
like that.)
  Your ".rhosts" file controls whether you will be prompted for a passwd.
Does your .rhosts file say:
+@all_systems	saleh

Mark

---

From: Mark Natoli <[email-masked]>
Date: Tue, 8 Sep 1998 16:57:53 -0400 (EDT)

On Tue, 8 Sep 1998, Saleh Elmohamed wrote:

> The only thing in the .rhosts is:
> 
> osprey1.npac.syr.edu
> osprey1-atm.npac.syr.edu
> osprey2...
> ...
> osprey8...

Try adding this to the bottom:

+@all_systems	saleh

Mark