Subject: Re: Timing

From: Saleh Elmohamed <[email-masked]>
Date: Sat, 18 Apr 1998 18:39:25 -0400 (EDT)

I didn't come across anything but here is something I quickly
put together

in your program you will this timing routine:

         Subroutine timer(return_time,initial_time)
         real, intent(in) :: initial_time
         real, intent(out) :: return_time
         integer finish,rate
          call system_clock( COUNT=finish, COUNT_RATE=rate)
          return_time = FLOAT(finish) / FLOAT(rate) - initial_time
          end

Well, in your main program you need to have an initial call to this thing

         call timer(tstart,0.0)

later you do the timing by doing the following

         call timer(tend,tstart)

to display the time, you say:

         write(6,*) 'Execution took:',tend,'seconds'

This should work like a charm :-) 
Yo need to buy me a dinner :-)

-Saleh

---

From: Saleh Elmohamed <[email-masked]>
Date: Sat, 18 Apr 1998 18:44:09 -0400 (EDT)

> Yo need to buy me a dinner :-)

also add

           real tstart,tend