Subject: Metaheuristics: references wanted

From: "J.K. Hao" <[email-masked]>
Date: Wed, 07 Jul 1999 09:26:47 +0200

Dear colleagues,

I'm looking for references on the origin of the term
"Metaheuristic" as well as its formal definition.
(who used it first time, in which context, what was
the initial definition...)

It is true that the term "Metaheuristic" is now largely accepted
by our community, but I'm no aware of any formal definition
of the term. Such a definition may be useful to explain to
people working in other areas what a metaheuristic is.
It is also indispensible for the decipline.

Thank you in advance for your answers.

All the best.

_________________________________________________________
Jin-Kao Hao
LGI2P, EMA-EERIE, Parc Scientifique G. Besse, 30000 Nîmes, France
email: [email-masked]
phone/fax: +33 4 66 38 70 53/74
http://www.site-eerie.ema.fr/~hao/group.html
_________________________________________________________

ATTENTION: New address from 1er September 1999
_________________________________________________________
Jin-Kao Hao
LERIA, Universite d'Angers, U.F.R Sciences, 2 Bd. Lavoisier, 49045
Angers, France
email: [email-masked] or [email-masked]
_________________________________________________________

---

From: Harvey Greenberg <[email-masked]>
Date: Wed, 7 Jul 1999 06:08:15 -0600 (MDT)

Fred Glover invented the term.  See the Mathematical Programming Glossary
at http://www.cudenver.edu/~hgreenbe/

Thanks,
Harvey
[email-masked]
http://www.cudenver.edu/~hgreenbe/

On Wed, 7 Jul 1999, J.K. Hao wrote:

> Date: Wed, 07 Jul 1999 09:26:47 +0200
> From: J.K. Hao <[email-masked]>
> To: [email-masked]
> Subject: Metaheuristics: references wanted
> 
> Dear colleagues,
>

---

From: Michael Pilegaard Hansen (Ph.d) <[email-masked]>
Date: Wed, 07 Jul 1999 14:19:49 METDST

> It is also indispensible for the decipline.

Dear Jin-Kao Hao,

To answer your question I send you a mail received by me from Fred Glover. 
In the mentioned paper, Fred writes that 'Tabu search may be viewed as a 
"meta-heuristic" superimposed on another heuristic'.

I reply to the entire mailinglist since it may be of interest to others.

Best regards,
Michael

Michael,
    The answer to your question -- and other related information -- can be
found in Chapter 1 of the book Tabu Search, in Section 1.9 titled
"Historical Note on Meta-Heuristics".  (I like "metaheuristics" better
than "meta-heuristics", and usually use the former, but used the latter
here because that was the way it was originally introduced.  Probably I'll
change that in the second edition of the book.)
    The short answer to your question is that the term was introduced in a
paper I published in 1986 called "Future Paths for Integer Programming and
Links to Artifical Intelligence," Computers and Operations Research, Vol.
13, pp. 533-549.
    In case you're interested in more details about the background and
current character of the metaheuristics area, you might check out the
Tabu Search book.  Further information about the book appears at the end
of this message.
     I hope these comments are useful.
Fred

On Wed, 18 Mar 1998, Michael Pilegaard Hansen wrote:

>
> Dear Professor Glover,
>
> I am currently finishing my ph.d. dissertation and have a problem
> finding an original reference to the term "metaheuristic".
>
> When I ask you it is due to my supervisor, Prof. Vidal, who seemed
> to recall that you at one point were the one introducing the term
> in optimization.
>
> If you have a published reference for this, or simply could answer
> via email, I would be much obliged.
>
> Best regards,
> Michael
>
> --
> Michael Pilegaard Hansen, Ph.D. stud.        Tel. +45 4525 5188/3396
> Department of Mathematical Modelling, 321    Fax. +45 4588 1397
> Technical University of Denmark              Email: [email-masked]
> DK 2800 Lyngby, Denmark                      http://www.imm.dtu.dk/~mph
>

---

From: Glover Fred <[email-masked]>
Date: Wed, 7 Jul 1999 10:16:18 -0600 (MDT)

Jin-Kao,
    I fear I am the culprit in originating the term "metaheuristics".  For
background and a rough attempt to explain the term, see the discussion of
metaheuristics in the first chapter of the book Tabu Search by Manuel
Laguna and me (Kluwer Academic Publishers).  Originally, it was written
"meta-heuristics" (and still sometimes is).
    But as usual, such things grow well beyond their origins, and the
remarkable deluge of innovative work over the last decade or so has been
responsible for putting the area "on the map".  So, independent of the
happenstance of coining the term, the field itself has been invented by
many. 
    Fred