Subject: mpiJava error

From: Sung-Hoon Ko <[email-masked]>
Date: Fri, 3 Jul 1998 13:10:42 -0400 (EDT)

Saleh,
if you got error
`java.lang.UnsatisfiedLinkError: no mpijava in shared library path'
on osprey 1, try osprey2 or 3.

On osprey1 it has a different `ld' version than others.

Try `ld -V' on osprey1 and it says:
ld: Software Generation Utilities - Solaris/ELF (3.0)

But on osprey2
ld: Software Generation Utilities (SGU) SunOS/ELF (LK-2.0 (S/I) -
versioning)

I believe `libmpi.so' in /opt/SUNWhpc/lib was compled with 
SunOS/ELF ld version.

---

From: Sung-Hoon Ko <[email-masked]>
Date: Fri, 3 Jul 1998 13:32:36 -0400 (EDT)

OK that's what we got.

Bryan, would you send this simple test tar file to sun?

On Fri, 3 Jul 1998, Saleh Elmohamed wrote:

> Date: Fri, 3 Jul 1998 13:24:27 -0400 (EDT)
> From: Saleh Elmohamed <[email-masked]>
> To: Sung-Hoon Ko <[email-masked]>
> Subject: Re: mpiJava error
> 
> Sung-Hoon,
> 
> I tried osprey2 and here is what I got:
> 
> 
> osprey2.npac.syr.edu% /opt/SUNWhpc/bin/tmrun -np 2 java test
> test.java: hello
> test.java: hello
> MPI.Init: hello
> len=0 
> Before MPI_Initialized ...
> After MPI_Initialized... flag = 0
> Before MPI_Init ...
> a.out: (TMTL UL) TMRTE_Init: tmrte_aout_Init: Bad file number
> TMTL_abort aborting process....
> MPI.Init: hello
> len=0 
> Before MPI_Initialized ...
> After MPI_Initialized... flag = 0
> Before MPI_Init ...
> a.out: (TMTL UL) TMRTE_Init: tmrte_aout_Init: Bad file number
> TMTL_abort aborting process....
> Signaled (core dumped).
> 
> 
> 
> Does it suppose to core dump?
> 
> 
> 
> On Fri, 3 Jul 1998, Sung-Hoon Ko wrote:
> 
> > 
> > Saleh,
> > if you got error