Subject: Proposal links

From: "Zheng, Qiang" <[email-masked]>
Date: Mon, 10 Apr 2000 12:29:31 -0400 (EDT)

Hi, Saleh,

Here are links.

http://sun.wes.hpc.mil:8080/proposal.html
http://class-server.npac.syr.edu:3768/cps615spring00-docs/cc00frb/proposal/proposal.htm
http://class-server.npac.syr.edu:3768/cps615spring00-docs/cc00ych/proposal.html

Regards,

                                                 - Zheng, Qiang

---

From: "Zheng, Qiang" <[email-masked]>
Date: Tue, 11 Apr 2000 11:40:41 -0400 (EDT)

Hi,

Thanks. I think it possible to do that. The student is familiar with F90
and F77 and she did good jobs in homework. So I think a way to work it out
is she provide the result of her program and we just look the code since
F90 is not a lot different from F77. How'd you think  of it?

Regards,

                                                 - Zheng, Qiang

On Tue, 11 Apr 2000, Saleh Elmohamed wrote:

> Hi Qiang,
> Could you take a look at this proposal and tell me what you think
> of it? She probably would have to do it in MPI-F77 rather than F90....
> At least in the past here at NPAC we couldn't get F90 run with MPI.
> 
> Thanks.
> 
> -Saleh
> 
> 
> 
>

---

From: "Zheng, Qiang" <[email-masked]>
Date: Tue, 11 Apr 2000 14:50:05 -0400 (EDT)

Hi,

I was wrong by saying that we don't have f90 compiler supporting MPI. I
just double checked and I found we have mpif90 in mpich1.2.0_p4_cc.  I
think I can use it.

Regards,

                                                 - Zheng, Qiang

On Tue, 11 Apr 2000, Saleh Elmohamed wrote:

> Hi Qiang,
> 
> If that is the case then it is OK with me as well. I may send her
> few comments on the things to measure when parallelizing a 
> sequential code... Things such as speed and scalability 
> are quite important. Scalability in the sense of how an increase in number
> of processors affect the speed of the code, etc...
> 
> -Saleh
> 
> 
> On Tue, 11 Apr 2000, Zheng, Qiang wrote:
> 
> > Hi,
> >

---

From: "Zheng, Qiang" <[email-masked]>
Date: Tue, 11 Apr 2000 15:06:45 -0400 (EDT)

I need some time to find F90 program. 

Regards,

                                                 - Zheng, Qiang

On Tue, 11 Apr 2000, Saleh Elmohamed wrote:

> Hi Qiang,
> 
> That is good. Can you check if you could actually use it?
> 
> Thanks,
> Saleh
> 
> 
> 
>

---

From: "Zheng, Qiang" <[email-masked]>
Date: Tue, 11 Apr 2000 15:20:03 -0400 (EDT)

I am sorry, the link is not valid now.

Regards,

                                                 - Zheng, Qiang

On Tue, 11 Apr 2000, Saleh Elmohamed wrote:

> There is a fortran 90 program written about 3 years ago by a student
> for cps615... You could find it at:
> 
> www.npac.syr.edu/projects/cpsed/summer98summary/examples/f90/f90.html
> 
> It is sequential...
> 
> -Saleh
> 
> 
> 
>

---

From: "Zheng, Qiang" <[email-masked]>
Date: Tue, 11 Apr 2000 15:38:45 -0400 (EDT)

mpif90 reported 50 errors and stopped. I don't know why. I am looking for
other code now.

Regards,

                                                 - Zheng, Qiang

On Tue, 11 Apr 2000, Saleh Elmohamed wrote:

> http://www.npac.syr.edu/projects/cpsedu/summer98summary/examples/f90/f90.html
> 
> This should work...
> 
> 
> 
> 
>