Subject: please vote for a larger address space for the JVM

From: Bill Hibbard <[email-masked]>
Date: Fri, 17 Dec 1999 13:00:13 -0600

The current JVM is limited to 2 GB of address space with 32-bit addresses.
Sun knows how to increase this but needs encouragement to give this work
priority.  You can encourage them by voting at:

  http://developer.java.sun.com/developer/bugParade/bugs/4216417.html

If you are not already a member of the Java Developer Connection you'll
need to join in order to vote, but its free and easy (just go to the link and it'll
tell you how).

One way to look at this is that on balanced systems memory should be a
certain fraction of total system cost.  2 GB is just too small a fraction and
decreasing.

Thank you,
Bill Hibbard
[email-masked]

---

From: Bill Hibbard <[email-masked]>
Date: Mon, 20 Dec 1999 10:18:25 -0600

Thank you for the correction and the information.  It would still be very useful
for Sun's JVM to support addresses longer than 32 bits, so please vote for this at:

Bill

Andreas Krall wrote:

> You write:
> This is wrong. The JVM is not limited to 2 GB of address space. There some
> implementation of the JVM which only support 2 GB, but there are at least
> two implementations which support 64-bit addresses: CACAO
> (http://www.complang.tuwien.ac.at/java/cacao/) and the implementation by
> COMPAQ.
>
> Andi
>
> [email-masked]               Andreas Krall
> http://www.complang.tuwien.ac.at/andi/   Inst. f. Computersprachen, TU Wien
> tel: (+431) 58801/18511                  Argentinierstr. 8/4/1851
> fax: (+431) 58801/18598                  A-1040 Wien     AUSTRIA     EUROPE