Subject: Re: correction to http://nhse.npac.syr.edu/hpccsurvey/orgs/concurrent/concurrent.html

From: David Brower <[email-masked]>
Date: Tue, 13 Jul 1999 23:08:39 -0700

It's the land of opportunity, if you can afford the
cost of living.  I'd guess housing here is 3-4X what
something in syracuse costs.  Like, say $1500 for a
fairly dumpy 2 br apartment, and up from there.

But there are zillions of startups, and everybody is 
hiring.  Assuming you are competent and have some 
marketable skill, it is not hard to find work.

if you have a resume, pass it on.

cheers,
-dB  

Saleh Elmohamed wrote:
> 
> Hi David,
> 
> Many thanks for the pointers.
> 
> We've received the info for that particular company from various
> sources... Therefore, it is quite possible that some of those dates
> passed on to us were not be quite precise. BTW, did you notice
> any other inaccuracies there?
> 
> We've not updated those pages for quite a while now... When I
> get the chance, hopefully soon before I leave, I probably
> will need to do that.
> 
> best regards,
> Saleh
> 
> ps/ How is your work with Oracle? I'm wrapping up my work here
> and thinking about heading west. Any good job opportunities
> you know of?
> 
> On Tue, 13 Jul 1999, David Brower wrote:
> 
> > The page says the 3200 series was introduced in 1982.  I had
> > the dubious distinction of having ported code from 7/32s (the
> > predecessor line) to 3220's and 3240s in late 1980 and early
> > 1981.  This was at a VAR who installed these things at end
> > customer sites by mid year.  Which I know because I quit that
> > job in NJ and moved to California that year.
> >
> > cheers,
> > -dB, SU '79
> >

---

From: Saleh Elmohamed <[email-masked]>
Date: Wed, 14 Jul 1999 12:53:02 -0400

Hi David,

Here is a copy of my resume'. I'd  appreciate your help
in this regard. Also would love to hear any comments or suggestions about
it.

Cheers,
Saleh
----------------------------------------cut here-------------------------
               Saleh Elmohamed
               111 College Place, CST Bldg
               NPAC, Rm 3-217
               Syracuse, NY 13244-4100

       email:      [email-masked]
       Telephone:  (315) 443-1073
       Fax:        (315) 443-1973

Career Objectives
-----------------
Interested in opportunities in software architecture,
distributed systems (via objects, messaging and 
components), visual processing, Java-based collaborative 
systems, large scale optimization, database systems 
particularly in issues of performance on clusters of 
SMPs, and high performance hardware/software architecture.

I also have worked on pattern/image recognition, therefore,
would be quite interested in any research or developments 
opportunities in this area as well. 

Looking forward to join a group of highly motivated and 
intelligent researchers/developers to work on some
of these or other fields of interest.

Education
---------
Bachelor of Science in Mathematics and Computer Science, Michigan. 
Master and PhD of Science in Computer Science, Syracuse.
Will be completing my PhD by 8/1999.

Areas of Knowledge & Experience
-------------------------------
My experience spans a number of software and 
hardware areas. Here are what I consider my areas
of expertise:

[A] Software Architecture: 
    1. Design, implementation, and analysis of process control
       and scientific software tools and algorithms.
    2. Design and implementation of graph-based software
       tools for real-time data filtering and analysis.
    3. Design and implementation of Java-based scientific 
       software tools for distance education on collaboratory
       systems.
    4. Optimization-based software tools.

[B] Distributed Computing: 
    This includes parallelism and its principles 
    of granularity, locality, load balance, coordination and 
    synchronization, and performance modeling. 
    The focus here is on the shared-memory model due to 
    its complexity in dealing with issues of cache coherence,
    memory consistency, locking, atomic exchanges, and 
    nonuniform memory access. In this model the toughest 
    things to deal with are issues of locking and memory 
    consistency, and the implications of these issues on 
    performance of database systems.

[C] Large-scale Collaborative Systems: 
    Involving net-based collaborative systems of community
    of agents. For this we make use of our knowledge in 
    message passing interfaces and active messages used
    for distributed (memory) systems.
    I have worked on a Java-based collaboration model that is 
    currently used for distance education, planning and
    scheduling.
    http://www.npac.syr.edu/tango/

[D] Combinatorial optimization methods: 
    This involve dealing with complex problems of routing 
    and scheduling, network design, and facilities
    location. One of my current research areas is in the 
    development of hybrid methods combining local search 
    and population-based, creating still more effective
    general purpose solution techniques.

[E] Large-scale Modeling and Simulation: 
    Involving commercially-sponsored work that I have work
    on of computational fluid simulation and circuit simulations.

[F] Heuristics and approximation algorithms.

                     -.-.-.-.-.-.-

As well as experience in other areas:

1. Parallel and Distributed/Shared-Memory 
   Computing and Programming Models on NUMA
   systems, SMPs, and clusters.
   http://nhse.npac.syr.edu/hpccsurvey/architecture/

2. CC-NUMA and Cache Coherence protocols. 
   Computer architecture, particularly parallel 
   architecture and the interplay between software
   and hardware.
   http://nhse.npac.syr.edu/hpccsurvey/architecture/

3. Scientific Computing using Java/MPI, C/MPI on 
   Networks of Workstations and High Performance Computer
   Architecture.

4. Parallel compiler runtimes.
   http://www.npac.syr.edu/projects/pcrc/

5. Database systems -- Oracle8, DB2; Algorithms for 
   data mining applications for e-commerce, etc.

6. Java & related technologies, such as EJB, and the use of
   CORBA services for scientific and engineering applications.

7. Knowledge-based Systems, Case-based Reasoning and
   Computational Geometry.

8. Distributed Object Protocols such as CORBA's IIOP.

9. Neural computing tools for image/pattern and speech
   recognition, and function approximation.

Software/Hardware Systems and Languages
---------------------------------------
1. Programming Skills: 
   Quite proficient in C, Java (since 96),
   Lisp, Prolog, Smalltalk, Fortran, C++,
   Modula-3, SQL, and (CGI/Perl).

   Parallel programming tools: MPI and PVM.
   Current work using: C/C++ - Java - Perl 
   (for preprocessing data, etc.)
          
2. OS knowledge and experience in: Unix, Solaris, 
   Linux, VMS, IRIX, and NT. 
   Current work: development on Solaris, NT, and Linux.

3. Hardware systems experience in:
   SUN UltraSparcs and Servers, HP Stations, 
   SGI Origin 2000, SGI Power Challenge, IBM SP-2, 
   Intel Paragon, Cray T3E/T3D, Compaq-DEC stations, 
   PCs, and Macs.
   http://nhse.npac.syr.edu
   Current work uses Clusters of SUNs, and a host 
   of Linux/NT-based PCs.

Related Work and Experience
---------------------------
[A] Systems and Software Engineer at BP-Texaco-Aramco, London
    and Dubai. 1984 - 1987, and on part-time bases from 1987 till
    1992. 
 1. With the Software Engineering Division: Work involved design and
    implementation of process control and data analysis and filtering
    software tools. 
 2. With the Database Division: Here my work mainly involved with
    tuning and performance analysis.

[B] Title: Development/Research Scientist
    Organization: Northeast Parallel Architectures Center, Syracuse,
    NY. Date: 1994 till now.

 1. Worked on High Performance Computing using MPI and Java/MPI 
    on clusters of NT-based and Sun workstations.

 2. Worked on designing a virtual programming laboratory (VPL) for
    programming in Java, Java/MPI, C/MPI, on a network of workstations 
    (SUN, Compaq-DEC, HP). 
    Currently part of NPAC web-based 
    distance education efforts, using
    a cluster of Sun Servers.
    http://www.npac.syr.edu/Education/Courses/CPS615/

 3. Designed and successfully implemented scheduling and
    timetabling for Syracuse University using optimization-based
    methods such as simulated annealing,
    mean field, TS, genetic algorithms and rule-based approaches. 
    Currently using Similar approaches for data mining, detection of
    credit card fraud, and resource allocation.

 4. Working on Java-based tools for collaborative computing. Mainly
    systems for application sharing, conferencing, scheduling, and
    distance learning.
    http://www.javagrande.org
    http://www.npac.syr.edu/tango/

 5. Fall 1996, 1997, and 1998 co-taught, with Geoffrey Fox,
    Computational Science for Simulation Applications
    and Parallel Computing. 
    http://www.npac.syr.edu/Education/Courses/CPS615/
    http://www.npac.syr.edu/users/saleh/homepage/PDC/
          notes-on-PDC/notes-on-PDC.html 
    As well as distributed information systems:
    http://www.npac.syr.edu/projects/cps606spring98/

 6. Working on Computational Methods for Distributed Information 
    Systems, using Java-related technologies, among others. 
    http://www.javagrande.org 
    http://www.npac.syr.edu/projects/tutorials/JavaCSE/

 7. Database Systems and JDBC on the Java side.

 8. Working on coupling message-passing & other programming 
    tools with Java for distributed and parallel computing.
    http://www.npac.syr.edu/projects/pcrc/index.html

 9. Worked on pattern/image recognition systems, 
    and graph matching using neural, genetic, and mean 
    field algorithms along with various statistical models.

 10. Working on hardware resources and software tools for NHSE.
     http://nhse.npac.syr.edu
     http://www.nhse.org

 11. Working on issues of software/hardware trade-offs
     in distributed computing environments.

 12. Data Analysis and data mining methods.

Languages and Communication Skills
----------------------------------
Have an excellent command of the English language 
as well as few others.

Sample of Recent Reports
------------------------
1. S. Elmohamed and G. Fox, 
   Integration of Java-based Scientific Tools for
   Education with the Collaboratory System (Tango): Case 
   study of Fluid Flow and Monte Carlo Simulation.
   (To appear in Journal of Physics C)

   ** MPI/Java demos of the Fluid Flow software were given at
      Supercomputing 1997 in San Jose and  Supercomputing 
      1998 in Orlando, by our colleague Bryan Carpenter. 
      http://www.npac.syr.edu/projects/pcrc/index.html

2. S. Elmohamed and G. Fox, 
   Some issues of reducibility and equivalence in 
   feedforward neural networks.
   (Revised 1999, submitted to IEEE Trans. on Neural Nets.)

3. S. Elmohamed, G. Fox, and P. Coddington,
   Optimization Networks and Annealing for scheduling 
   on a cluster of workstations, NPAC Tech Report,
   Syracuse University, 1997. 
   (Revised 1999, submitted to Journal of Physics C)

4. S. Elmohamed, G. C. Fox, and P. Coddington,
   A Comparison of Annealing Techniques for Academic Course
   Scheduling, Springer-Verlag Lecture
   Notes in Computer Science, Volume 1408, 1998.

Other Online Work
-----------------
That I have worked on and some is work in progress.

1. Parallel Compiler Runtime Consortium.
   http://www.npac.syr.edu/projects/pcrc/

2. Parallel software/hardware for the NHSE:
   http://www.nhse.org
   http://nhse.npac.syr.edu/hpccsurvey/
   http://nhse.npac.syr.edu/hpccgloss/
   http://nhse.npac.syr.edu/hpccsurvey/architecture/

3. Java for Computational Science and Engineering.
   http://www.javagrande.org
   http://www.npac.syr.edu/projects/tutorials/JavaCSE/

4. CD-ROM materials for the US Army Corps of Eng. (CEWES)
   http://osprey6.npac.syr.edu:8080/
          and
   http://www.wes.hpc.mil/pet/CEWES/CEWES_frame.html

5. Computational Science and Engineering Materials.
   http://www.npac.syr.edu/projects/cpsedu/CSEmaterials/

6. Collaborative systems for distance education, and 
   command & control problems.
   http://www.npac.syr.edu/tango/

7. Classes I co-taught or assisted in setting up and 
   teaching in the past 3 years.
   http://www.npac.syr.edu/projects/cps606spring98/
   http://www.npac.syr.edu/Education/Courses/CPS615/

Few References
--------------
1. My boss and the first to be contacted:
         
   Professor Geoffrey C. Fox, 
   Director, NPAC, 111 college
   place, CST Bldg, Rm 3-217, 
   Syracuse, NY 13244-4100.   
   phone: 315-443-2163
   email: [email-masked]

2. Dr. Paul D. Coddington, 
   Department of Computer Science, 
   University of Adelaide, 
   Adelaide, SA 5005,
   Australia.
   email: [email-masked]

3. Professor Ernest Sibert,
   Engineering and Computer 
   Science, 111 College Place, 
   CST Bldg, Rm 2-120, 
   Syracuse, NY 13244.
   phone: 315-443-3110
   email: [email-masked]

4. Dr. Bryan Carpenter, 
   Senior Research Scientist, 
   NPAC, 111 College Place, 
   CST Bldg, Rm 3-217, 
   Syracuse, NY 13244-4100.
   phone: 315-443-5068
   email: [email-masked]

5. Dr. Nancy McCracken, 
   Engineering and Computer Science,
   Syracuse University, 
   111 College Place, CST Bldg,
   Syracuse, NY 13244.
   phone: 315-443-4687
   email: [email-masked]

Work Location, etc.
-------------------
* I can relocate to other regions in
  the US.
* I do have work authorization.
* Starting date: August 99.

====================================================================

---

From: David Brower <[email-masked]>
Date: Wed, 14 Jul 1999 10:30:30 -0700

> in this regard. Also would love to hear any comments or suggestions about

I've forwarded it on to one group, and will pass it on generally
if they aren't interested.

cheers,
-dB