Subject: Question (fwd)

From: Adam Gaither <[email-masked]>
Date: Mon, 11 Jan 1999 14:27:57 -0600

Thanks for all of your responses.  I should note that only two of the
responses had the same idea (it is the easiest one)...

Adam
    _______
   /       |
  /        |===================================================================
 /Starkville Adam Gaither                        Mississippi State University |
 /       * | Senior Systems Integration Analyst  Engineering Research Center  |
 \         | Fax: (601)325-7692                  2 Research Blvd.             |
  |        | Phone: (601)325-2067                Starkville, MS               |
  /        | [email-masked]                39759                        |
 /         |===================================================================
|______    |
      /    |
      \____|

Favorite quote:  "I can explain it for you, but I can't understand it for you."

---------- Forwarded message ----------
Date: Mon, 11 Jan 1999 15:14:17 -0500
From: Geoffrey Fox <[email-masked]>
To: Adam Gaither <[email-masked]>
Subject: Question

Geoffrey Fox  [email-masked],   http://www.npac.syr.edu 
Director of NPAC and Professor of Physics and Computer Science
Phone 3154432163 (Npac central 3154431723) Fax 3154434741

------- Forwarded Message

Date:    Mon, 11 Jan 1999 15:00:54 -0500
From:    Hasan Timucin Ozdemir <[email-masked]>
To:      Geoffrey Fox <[email-masked]>
Subject: Re: You can give a pointer?

Hi,

He can open a connection from C++ through sockets to JavaServlet and
posts its data (and/or message) within a MIME request.
It should behave like a browser.

Regards,

On Mon, 11 Jan 1999, Geoffrey Fox wrote:

> 
> Geoffrey Fox  [email-masked],   http://www.npac.syr.edu 
> Director of NPAC and Professor of Physics and Computer Science
> Phone 3154432163 (Npac central 3154431723) Fax 3154434741
> 
> ------- Forwarded Message
> 
> Date:    Mon, 11 Jan 1999 09:46:49 -0600
> From:    Adam Gaither <[email-masked]>
> To:      [email-masked]
> Subject: Re: excerpt of RMI section from JDC Newsletter Vol. 1 No. 11 (fwd)
> 
> 
> Hello,
> 
> I am looking for an example (or idea) of how to use a C++ client with 
> a JAVA server or servlet.  I have asked four different people here and I
> have four different answers of how to do this.  If you are interested:
> 
> I am trying to connect an X/Motif gui with a server to a "persistant
> object" that is memory and compute intensive.  I am going to model
> the server with JAVA and compute with C++ and FORTRAN.  I am NOT using
> a web browser as an interface.  I would simply like JAVA to handle
> the network connection and communication.  The information passed
> between the server and client consists of arrays and queries on the
> arrays.
> 
> Any ideas/examples?
> 
> Thanks for your help,
> 
> Adam
> 
>     _______
>    /       |
>   /        |=================================================================
==
>  /Starkville Adam Gaither                        Mississippi State University
 |
>  /       * | Senior Systems Integration Analyst  Engineering Research Center 
 |
>  \         | Fax: (601)325-7692                  2 Research Blvd.            
 |
>   |        | Phone: (601)325-2067                Starkville, MS              
 |
>   /        | [email-masked]                39759                       
 |
>  /         |=================================================================
==
> |______    |
>       /    |
>       \____|
> 
> Favorite quote:  "I can explain it for you, but I can't understand it for you
."
> 
> 
> 
> ------- End of Forwarded Message
> 
> 

------- End of Forwarded Message

---

From: "George K. Thiruvathukal" <[email-masked]>
Date: Mon, 11 Jan 1999 14:39:03 -0600

Adam,

If you are connecting to a "servlet" your Java program can directly use
the URL class to open a connection and use it. You would not need to use
sockets as prescribed below.

George