Subject: Re: image loading in java applet

From: John Lou <[email-masked]>
Date: Fri, 6 Nov 1998 16:52:49 -0800 (PST)

I did use MediaTracker to synchronize image loading,
but it doesn't seem to solve the problem I mentioned.

John

> From [email-masked] Fri Nov  6 16:50 PST 1998
> X-Authentication-Warning: postoffice.npac.syr.edu: majordom set sender to owner-java-for-cse using -f
> Organization: Loyola University
> X-Mailer: Mozilla 4.5 [en] (WinNT; U)
> X-Accept-Language: en
> MIME-Version: 1.0
> To: John Lou <[email-masked]>
> CC: [email-masked], [email-masked],
>         [email-masked], [email-masked]
> Subject: Re: image loading in java applet
> Content-Transfer-Encoding: 7bit
> Sender: [email-masked]
> X-Lines: 29
> 
> I know that when working with images as a general rule, you should use
> MediaTracker.
> 
> Image loading is done with threads, and the MediaTracker class is a
> helper class that allows the user to "wait" for the Image to be
> fully-loaded.
> 
> George
> 
> John Lou wrote:
> > 
> > Hi,
> > 
> > When using the getImage() method in an applet to load
> > images, it seems getImage() won't load a new image
> > from a given path (which is an argument to getImage())
> > if the image was loaded before. In other words,
> > getImage() still returns the old image that
> > was loaded last time, even though the image for the given
> > path has been changed since the last load.
> > 
> > I hope to have getImage() load the image again from
> > the given path everytime it is called, but can't
> > figure out how to do that. Any help is very much
> > appreciated.
> > 
> > John Lou
> > Jet Propulsion Laboratory
> > [email-masked]
>

---

From: Sami Rantala <[email-masked]>
Date: Thu, 12 Nov 1998 11:59:25 +0200

> but it doesn't seem to solve the problem I mentioned.

It seems that vm caches images to somewhere and it is not possible to
empty it. Create an servlet where from your applet asks the new image
name and load it with that. 

--

Sami Rantala

---

From: Sami Rantala <[email-masked]>
Date: Thu, 12 Nov 1998 11:59:25 +0200

--

Sami Rantala