Subject: Re: JavaOne PDF slides ...

From: David Nelson-Gal <[email-masked]>
Date: Mon, 21 Jun 1999 12:02:16 -0700 (PDT)

The current MicroSoft SDK doesn't handle extremely large numbers of connections 
like Solaris does. At 3500 connections, IBMs 1.1.7 VM on Windows still works 
though at a much lower rate. No other VM seems to handle more than 4000 
connections effectively. We have measured the Solaris JDK at over 8000 
connections on this application but it doesn't work much further than that. So 
you could say that drops Solaris to Windows performance at about 8500 
connections when it joins it at zero but I don't think that is interesting.

The optimizing JIT is approaching a Beta release. If you are interested in 
joining the beta program, we could make it available to you in July. 

The fundamental differences between the 2 JITs are in the tradeoffs between 
compilation speed over performance. The FastJIT has a "budget" of about 5000 
instructions per byte code (current rate is about 3500i/bc). Within this budget, 
the FastJIT tries to generate the best code it can, doing some basic 
optimizations but not the truly sophisticated ones. If you think of Unix C 
compilers, the FastJIT is like compiling with optimization level somewhere 
between -O1 and -O2. With the optimizing JIT, we are more focused on generating 
the best code we can. With that in mind, it uses closer to 100,000 instructions 
per bytecode and can achieve similar optimizations found at -O3 and -O4 levels 
in the Unix C compiler. This is because we can do a 2-level intermediate form 
which allows various things ranging from dead-code elimination, loop 
optimizations and more aggressive inlining, to peep-hole and instruction 
scheduling optimizations.

The offline compilation is a long discussion. Perhaps if we get a chance to 
meet, we can talk more about it.

DaveNG

> Date: Thu, 17 Jun 1999 23:13:48 -0400
> From: Saleh Elmohamed <[email-masked]>
> Subject: JavaOne PDF slides ...
> To: [email-masked]
> MIME-version: 1.0
> 
> Hi David,
> 
> It was nice meeting you few months ago.
> 
> Checking JavaOne presentations in the past couple days, 
> I came across yours. You got some interesting points there ...
> 
> In the 'scalability under load' slide you have a plot
> of no. connection vs. msgs/sec done few months ago, at
> the shown rate, do you think that some large no. of 
> connection, let say maybe 10 time the max number shown,
> solaris java 2 and MS sdk 3.1 share a point in the
> rate of message/sec?
> The latter looks like somewhat flattening out...
> 
> You also mentined somewhere there JIT'ing offline; 
> what is the big advantage of that or will that buy 
> more pereformance than online JIT'ing? If that is the 
> case then just do an offline 'optimized' traditional 
> compilation and skip online JIT'ing altogether.... 
> 
> Also, will be inetersted to try out the optimized JIT,
> I think you mentioned that it will be out sometimes in the
> fall. BTW, what is significantly different between it and
> the current fast JIT, or rather, what has been added
> or incorporated for higher optimization?
> 
> I have few more questions but will leave them till another
> email ...
> 
> talk to you later,
> Saleh
> 
> 
> 
> 
> 
> 

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

David Nelson-Gal			voice: (650) 786-6351
Director of Java Technology		fax:   (650) 968-6396
Solaris Software, Sun Microsystems	pager: (800) 970-5796
901 San Antonio Rd. ms: MPK16-301	email: [email-masked]
Palo Alto, CA 94303			web:   http://www.sun.com/solaris/java

---

From: David Nelson-Gal <[email-masked]>
Date: Mon, 26 Jul 1999 14:47:30 -0700 (PDT)

I forwarded your mail to the person managing the Beta program.

> Date: Sat, 24 Jul 1999 16:29:47 -0400
> Subject: Re: JavaOne PDF slides ...
> To: David Nelson-Gal <[email-masked]>
> MIME-version: 1.0
> 
> Hi David,
> 
> On Mon, 21 Jun 1999, David Nelson-Gal wrote:
> 
> > 
> Has this been released yet?
> I'd be interested in joining in.
> 
> best wishes,
> Saleh
> 
>