Subject: factoring example..

From: [email-masked]
Date: Wed, 18 Feb 1998 14:01:17 +0900

Dear everyone
Does anyone has java factoring example?
I would like to get a sample program of factoring.
If you know it, please let me know it......
Thanks in advance.

---

From: Anthony Colyandro x3422 <[email-masked]>
Date: Wed, 18 Feb 1998 08:42:44 -0700 (MST)

What type of factoring example do you need?

There is a numerical library for java for 
free and it contains some matrix decomposition
classes.  I went to the web site and copied
the description of the classes.

Here is the information:

--------------5DE4EA51BD04B5B7B4C558FD
Content-Type: text/plain; charset=iso-8859-1
Content-Transfer-Encoding: 8bit

http://www.vni.com/products/wpd/jnl/JNL/docs/overview.html

>
> Overview of JNL, a Numerical Library for JavaTM
>
> JNL, a Numerical Library for Java, is a set of classes for the most important 
numerical functions missing in Java. The library is comprised of one numerical 
type class, Complex, and three categories of numerical functions classes: the 
special functions class, the linear algebra classes, and the statistics class. 
All classes use double precision floating point as the underlying float type. 
These classes are described below.
>
> Complex Numbers
>
> The class Complex instantiates an object as being of type Complex and provides 
methods for double precision complex arithmetic. Methods for the addition, 
subtraction, multiplication, division, negation, and conugation of complex 
numbers are included. These methods are overloaded to allow for mixed double and 
Complex operands.
>
> Linear Algebra
>
> The linear algebra classes manipulate rectangular or square arrays of type 
double or Complex. A rectangular matrix is a double[][] or Complex[][] with all 
of its rows the same length. A square matrix is a rectangular matrix with the 
number of columns equal to the number of rows. All matrices are row major with 
zero as the index of the first element of any row or column.
>
> The class DoubleVector contains static methods for manipulating vectors. It 
does not define a vector object; it is not possible to create an instance of 
DoubleVector. There are methods for vector norms, maximum and minimum elements, 
and dot product.
>
> The class DoubleMatrix contains static methods for manipulating matrices. It 
does not define a matrix object; it is not possible to create an instance of 
DoubleMatrix. There are methods for matrix multiplication, inversion and solving 
linear systems.
>
> The classes DoubleCholesky, DoubleLU, DoubleQR and DoubleSVD encapsulate 
standard matrix decompositions. Their constructors take a matrix as an argument 
and compute the decomposition. This may throw an exception. Other member  
functions are then used to use or return parts of the decomposition.
>
> Analogous to these classes for double-precision arrays there are also classes 
for Complex arrays. They are class ComplexVector, class ComplexMatrix, 
ComplexCholesky, ComplexLU, ComplexQR and ComplexSVD.
>
> Special Functions
>
> The class Sfun contains a collection of special functions. This class is 
analogous to the existing class java.lang.Math, but contains more advanced 
functions. This class is a collection of static member functions and data; it 
cannot be instantiated.
>
> Statistics
>
> The class Statistics contains a collection of basic statistical functions. 
This class is a collection of static member functions; it cannot be 
instantiated.
>
>
> Copyright © 1997 - Visual Numerics, Inc.

http://www.vni.com/products/wpd/jnl/jnl_new.html

>
> JNL 1.0 - A Numerical Library for Java TM
>
> Change Tracking for the JNL
>
> New in Revision F
>
>    * Made code changes to eliminate possible non-thread-safe situations.
>    * Changed default tolerance used by SVD routines.
>    * Replaced element-by-element copies with system array copies where  
possible.
>    * Removed unnecessary initialization of arrays where possible.
>    * Improved performance of class ComplexSVD.
>    * Moved documentation directory to same level as Classes directory.
>
> New in Revision E
>
>    * Added determinant method for classes DoubleLU and ComplexLU.
>    * Added transpose method for classes DoubleMatrix and ComplexMatrix.
>    * Removed the "final" restriction on all public classes.
>    * Fixed bug in condition number method for classes DoubleLU and ComplexLU.
>    * Added classes DoubleVector, ComplexVector, DoubleCholesky, and 
ComplexCholesky to the JNL.
>    * Added methods for matrix norms, dot product, and max/min to the 
DoubleMatrix and ComplexMatrix classes.
>    * Added generalized inverse to classes DoubleSVD and ComplexSVD.
>    * Removed restriction of square matrices only from classes DoubleQR and 
ComplexQR.
>    * Added solve method to classes DoubleQR and ComplexQR.
>    * Added additional rank method to classes DoubleQR and ComplexQR.
>    * Overloaded the solve method in classes DoubleMatrix and ComplexMatrix to 
handle Least_Squares problems.
>    * Renamed "double info" and "double rank" methods to "int info" and "int 
rank".
>    * Fixed a bug which affected inverseFCdf, inverseTCdf, tCdf, skew, and 
kurtosis for class Statistics.
>    * Added more information to documentation for all classes.
>
> New in Revision D
>
>    * Added Numerics
>    * Added the list of interesting Excel functions for consideration in the 
JNL.
>
> New in Revision C
>
>    * Made major implementation changes.
>    * Used arrays instead of adding new classes for vector and matrix. This 
limits the infix overloading to arrays.
>
> New in Revision B
>
>    * Created a new Website Layout.
>    * Made minor changes to the Specification.
>    * Added API documentation for Complex and Special Function classes.
>    * Added SmartTable: ExcelTM to Java Applet Tool.
>    * Added SmartTable Numerics.
>    * Consolidated Comments from Revision A.
>    * Added a Forum for future discussions.
>
> Comments to Java Jim
>
>
> Copyright © 1997 - Visual Numerics, Inc.®

--------------B7C98C40B6F24D27C88C0E72
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

http://www.vni.com/products/wpd/jnl/jnl_new.html">http://www.vni.com/products/wp
d/jnl/jnl_new.html

JNL 1.0 - A Numerical Library for Java TM

Change Tracking for the JNL

New in Revision F

 * Made code changes to eliminate possible non-thread-safe
situations.
 * Changed default tolerance used by SVD routines.
 * Replaced element-by-element copies with system array
copies where possible.
 * Removed unnecessary initialization of arrays where possible.
 * Improved performance of class ComplexSVD.
 * Moved documentation directory to same level as Classes
directory.

New in Revision E

 * Added determinant method for classes DoubleLU and ComplexLU.
 * Added transpose method for classes DoubleMatrix and
ComplexMatrix.
 * Removed the "final" restriction on all public classes.
 * Fixed bug in condition number method for classes DoubleLU
and ComplexLU.
 * Added classes DoubleVector, ComplexVector, DoubleCholesky,
and ComplexCholesky to the JNL.
 * Added methods for matrix norms, dot product, and max/min
to the DoubleMatrix and ComplexMatrix classes.
 * Added generalized inverse to classes DoubleSVD and ComplexSVD.
 * Removed restriction of square matrices only from classes
DoubleQR and ComplexQR.
 * Added solve method to classes DoubleQR and ComplexQR.
 * Added additional rank method to classes DoubleQR and
ComplexQR.
 * Overloaded the solve method in classes DoubleMatrix
and ComplexMatrix to handle Least_Squares problems.
 * Renamed "double info" and "double rank" methods to "int
info" and "int rank".
 * Fixed a bug which affected inverseFCdf, inverseTCdf,
tCdf, skew, and kurtosis for class Statistics.
 * Added more information to documentation for all classes.

New in Revision D

 * Added Numerics
 * Added the list of interesting Excel functions for consideration
in the JNL.

New in Revision C

 * Made major implementation changes.
 * Used arrays instead of adding new classes for vector
and matrix. This limits the infix overloading to arrays.

--------------B7C98C40B6F24D27C88C0E72--

> From [email-masked] Tue Feb 17 22:09 MST 1998
> X-Authentication-Warning: postoffice.npac.syr.edu: majordom set sender to 
owner-java-for-cse using -f
> From: [email-masked]
> To: "[email-masked]" 
<[email-masked]>
> Subject: factoring example..
> Date: Tue, 17 Feb 1998 22:01:17 -0700
> Encoding: 5 TEXT
> 
> Dear everyone