Subject: Java/vrml

From: "Abdul H. Aziz" <[email-masked]>
Date: Wed, 06 Jan 1999 15:02:37 -0500

Hi,

Has anyone combined Java and vrml?

Details:

We have an applet.  How can we talk to it from VRML using Netscape?

More specifically:

We have an applet (Java) that is embedded in the page (MAYSCRIPT). From
VRML (within Netscape) we want to execute the applet's public methods.

i.e. from VRML we want to call document.Applet.test();
     where Applet is the name of the Applet and test is a public method
     within the Applet.

Has anyone done this before?  How can we approach it?

Thanks
Abdul

---

From: Mary Thomas <[email-masked]>
Date: Wed, 6 Jan 1999 12:38:54 -0800 (PST)

This can be done..check out the vrml repository
at SDSC, this should get you started:
  
  http://vrml.sdsc.edu/

|>=<|>=<|>=<|>=<|>=<|>=<|>=<|>=<|>=<|>=<|>=<|>=<|>=<|>=<|>=<|
 Mary P. Thomas                     Voice: (619) 534-5061 
 Scientific Computing Group         Fax:   (619) 534-5117 
 San Diego Supercomputer Center    
 P.O. Box 85608                     Email: [email-masked] 
 San Diego, CA 92186-5608           URL:   www.sdsc.edu/~mthomas

---

From: "Abdul H. Aziz" <[email-masked]>
Date: Wed, 06 Jan 1999 16:09:30 -0500

Could you please be more specific on what part of the SDSC repository I
could look at?  --Thanks.