Subject: Microsoft complies with Sun's JavaSpec

From: [email-masked] (Omer F Rana)
Date: Sun, 24 Jan 1999 13:42:36 +0000 (GMT)

Just thought this may of interest to folks on this list:

-----
J++ complies with Java 
By Antone Gonsalves, PC Week Online 

Microsoft Corp. said Thursday it has released a
service pack for Visual Studio 6.0 that makes
Visual J++, the suite's Java IDE, compliant
with a court order stemming from the Sun
Microsystems Inc. lawsuit.

"We are absolutely in compliance with the
preliminary injunction at this point," Lead
Product Manager Bill Dunlap said of Visual J++.

Service Pack 2 includes a new Java Virtual
Machine that supports the Java Native Interface
(JNI) and switches the tool's default development
mode from Windows extensions to the Java
language to development in cross-platform Java,
Dunlap said.

In addition, if a developer chooses to let the tool
add Windows extensions to his application, a
message box will warn him that the application
will only run on the Windows platform.

"There is a change in the user experience," Dunlap
said. "But the actual functionality of the tool and
the applications that you build are unchanged
from before."

The service pack is available in two versions: one
containing only bug fixes and updates to key
executables to Visual Studio; the other. also
including debugging libraries for C++ developers.

U.S. District Court Judge Ronald H. Whyte
handed down in November a preliminary
injunction giving the Redmond, Wash., company
90 days to conform any product that ships with
Java technologies to Sun's standards.

Sun claimed Microsoft
had violated its contract as a
Java licensee by not following those standards.

The products affected included Internet Explorer
4.0, Windows 98, Windows NT 4.0 and Visual J++.

---

From: "George K. Thiruvathukal" <[email-masked]>
Date: Sun, 24 Jan 1999 09:51:55 -0600

Omer,

Thanks for putting this up. I had seen this but not completely
believed...

There are a few things people might want to know. In classic Microsoft
fashion, it's not clear what is to be download. Here's a summary of what
one needs.

This link will give you the latest JVM and plug it into your Windows
world:
    http://www.microsoft.com/msdownload/java/vm/3165/msjavx86.asp

This link will give you the SDK version 3.1, similar to the JDK +
Microsoft "goodies," which includes a new JVM:
    http://www.microsoft.com/msdownload/java/sdk/31f/SDKSETUP.asp

And this link will give you RMI, which is *not* covered by the
injunction and thus has not be included directly in Microsoft's SDK:
    ftp://ftp.microsoft.com/developr/MSDN/UnSup-ed/rmi.zip

Cheers,
George

---

From: "George K. Thiruvathukal" <[email-masked]>
Date: Sat, 30 Jan 1999 10:09:01 -0600

Hi Everyone:

There's one issue everyone who read this announcement with enthusiasm
might want to note. If you depend on RMI for your work, you will note
that it's conspicuously absent from the latest SDK release from
Microsoft. The title of this article is perhaps better expressed as "J++
complies with Java ruling." The ruling itself does not cover RMI, and
Microsoft notes on its "java" web that RMI is only available as a
separate download. In looking further, all of the RMI tools are missing
from the file I downloaded, which did not surprise me all that much.

The end of this war does not appear to be in sight.

George