Subject: code conversion using Java compiler

From: Ronald Michaels <[email-masked]>
Date: Sun, 10 May 1998 00:06:24 +0000

Hi - 

Does anyone have a success story about using a Java compiler (as it is
called) to convert Java class files to C code which can then be compiled
to executable using a C compiler.

I have used the Java Numerical Library JNL 1.0 rev F method ComplexSVD
with
TowerJ-0.2.1.0-x86-linux java compiler.  This is running under RH5.0.

http://www.vni.com/products/wpd/jnl/  for JNL

http://www.towerj.com/.c3/x86-linux/index.htm  for TowerJ

The application compiles to class files using the Blackdown 1.1.3 JDK
javac compiler and runs using the java interpreter without problem.

When I attempt to compile the class files using the tj compiler I get
the below error message. 

Has anyone encountered a similar problem either with the JNL or other
class library?

Any advice would be appreciated.  

I would very much like to hear from anyone who has successfully
converted JNL classes to C code. Linux is my first choice, but I would
use a Win95 tool if necessary.

Thanks - Ron

--- begin message ---

[rbm@localhost java_dev]$ tj -root_classes testCSVD
testCSVD/usr/local/TowerJ/lib/x86-linux/jopt1 -nojsysopt -norewrite
-tjdb Tjdb -project Project.tj -root_classes testCSVD
Checking for changed .class files...
Analyzing java/lang/Object
Analyzing java/io/Serializable
Analyzing java/lang/String
Analyzing java/lang/Exception

---

From: Kirk Abbott <[email-masked]>
Date: Sun, 10 May 1998 00:06:43 -0400

> use a Win95 tool if necessary.
Hello,
Your error message seems to have been truncated.
Unfortunately I dont have any experience with JNL. I have
played with towerj though. I never pursued it as I was horrified
at the size of the code that was generated.
There are a number of tools out there in different stages of
development to convert java -> C
                       .class -> C
                       (java/.class) -> native
toba comes to mind (still at 1.0.2)
harissa (same situation)
j2c
j2C++
ibms native compiler (does handle dynamic loading)
asymetrix supercede (native compiler for wintel)
symantec visualcafe (native compiler for wintel).
In addition you make want to look at
http://Meurrens.ML.org/ip-Links/Java/codeEngineering/

Hope this helps.
Kirk.