Subject: Java IDL in Java2'

From: [email-masked] (Omer F Rana)
Date: Sun, 28 Feb 1999 15:08:11 +0000 (GMT)

Hi,

The CORBA ORB that comes with Java1.2 (Java2) seems to work
quite well -- I have tried a few examples and they seem to
respond well. 

I was wondering however whether anyone had tried to connect
to the CORBA server via an applet? It seems that the JVM inside
Netscape and IE4 implement a modified version of JDK1.1 -- and
seem to throw up all kinds of weird and wonderful exceptions
when trying to implement an applet. I have also heard of the 
Java1.2 plug-in, anyone know how this works?

Have I done something drastic ... or is this still on the 
drawing board?

regards
Omer

-- 
work:+44 (0)1222-875542 / otherwise:+44 0956-299981 / parallel and scientific 
computing group / room S2.03 / dept of computer science / university of wales
- cardiff / po box 916 / cardiff cf2 3xf / uk / email: [email-masked]

---

From: "George K. Thiruvathukal" <[email-masked]>
Date: Sun, 28 Feb 1999 10:18:12 -0600

Omer,

The Java Plug-in probably is the way to go. It is fairly trivial to do the
installation.
The key thing you need to do after installation is to figure out how to script
the applet.
As I recall, the <APPLET>...</APPLET> must be replaced with some JavaScript.

The other thing you may want to look into is whether the CORBA code is available

separately from OMG. The package name is prefixed by org.omg, leading me to
believe that this might be the case.

Cheers,
George