Subject: SciMark over 100 achieved

From: [email-masked]
Date: Mon, 2 Nov 1998 13:25:00 -0500

It is my pleasure to report that the first SciMark composite score above
100 has been achieved.

The experiments were executed on an RS/6000 SP 332 MHz SMP node. This
machine has 4 PowerPC 604e processors, running at 332 MHz. The Java
environment was JDK 1.1.4 + IBM JIT for AIX.

Composite score for a single instance of the benchmark (java scimark 2.0)
is 115.6! The detailed score is as follows:

java scimark 2.0
Composite Score: 115.64274883526916
FFT (4096): 198.52516139343396
Jacobi SOR (100x100): , 10 iterations: 229.8070013847594
Monte Carlo (25000): 89.94731895898161
Sparse matmult (nz=25000): 59.93426243917074
LU (100x100): 63.721219928677684

Since the machine has four processors, I also performed a "scalability
experiment" by running four instances of the benchmark concurrently. The
(arithmetic) mean composite score is 114.8, or a degradation of only 0.70%
when going from one instance to four parallel instances.

Jose E. Moreira
([email-masked])
IBM T. J. Watson Research Center
Yorktown Heights NY 10598

---

From: Roldan Pozo <[email-masked]>
Date: Mon, 02 Nov 1998 16:42:22 -0500

Gregor,

SciMark scores are only meaningful within Java,
as the benchmark is based on JVM bytecodes rather than
source code.  However, we have done extensive
testing on dense linear algebra kernels (which make
up ONE component of SciMark) and have been able to 
achieve up to 1/2 the performance of optimized Fortran/C
in various BLAS calls.  This requires a good JIT and
performing many of the standard optimizations (loop unrolling,
constant-folding, etc.) by hand.  The code is not pretty, but
it _can_ be done...  If you write "elegant" Java, your
performance will be more like 10-20%...

Hope this info helps.

Regards,
Roldan

Gregor von Laszewski wrote:

> As a point of reference, I would find it useful to also include the C
> performance of the numerical report in this report. Is there a C scimark
> available?