Subject: Re: your mail

From: Zheng Gengbin <[email-masked]>
Date: Fri, 15 Nov 1996 09:59:19 +0800 (EAT)

I just log on the naos , and check this problem  , I found these 
problems on hpf2dep :

...Compiling detour.f90
Segmentation Fault - core dumped
...Compiling discover+.f90
Segmentation Fault - core dumped
...Compiling history.f90
Segmentation Fault - core dumped
...Compiling isoweight.f90
Segmentation Fault - core dumped
...Compiling moving.f90
..Compiling survey.f90
Segmentation Fault - core dumped
...Compiling tour.f90
Segmentation Fault - core dumped

	Maybe hpfsc did not reveive a correct .dep when you tested . 
And one more thing must remember , you cannot hpfsc a .dep file  for more than 
one time , this will cause some core dump also .

Zheng 

On Wed, 13 Nov 1996, Xinying Li wrote:

> 
> By the way, I test the present version of hpffe on 
> solaris (naos.npac.syr.edu).It reports some core-dump in hpfsc.
> 
> Would you check them?
> 
> ...Second pass compiling  discover+.dep
> Preprocessing ...
> Preprocessing done. 
> Segmentation Fault - core dumped
> ...Second pass compiling  history.dep
> Preprocessing ...
> Preprocessing done. 
> Segmentation Fault - core dumped
> ...Second pass compiling  isoweight.dep
> Preprocessing ...
> Preprocessing done. 
> Segmentation Fault - core dumped
> 
> Same thing happened to many files include "test1.f".
> 
> Li Xinying
> 

***************************************************************************
*     Zheng Gengbin                 *                                     *
*                                   *                                     *
*  Dept. of Computer Science        *  Phone:  86-10-2585088              *
*         & Technology              *  Email:                             *
*                                   *      [email-masked]   *
*  Peking University P.R.China      *  Mail:                              *
*                                   *      Room 1077 ,Building 47,        *
*                                   *      Peking University, P.R.China   *
***************************************************************************

---

From: Zheng Gengbin <[email-masked]>
Date: Fri, 15 Nov 1996 10:41:02 +0800 (EAT)

I found on nova , flex cannot accept -l , and /usr/bin/cc complain
the hpflexer.c produced by flex that yy_at_bol did not defined .

	So , I use this method to let it compiled :

	setenv LEX lex ; ./configure 

	To let it go , I must force the configure to use lex instead of 
flex .

Zheng