Subject: Re: Fix source & Version 1.69

From: Zheng Gengbin <[email-masked]>
Date: Tue, 26 Nov 1996 10:56:03 +0800 (EAT)

According to Guansong's suggestion , this new version remove the
FixSource in hpfsc which will change the source code during compile time. 
This version is also mainly for test , if you find any error when hpfsc 
cannot found the intrinsic library , please inform me . If this version proved 
to be successful , we can apply to error.file .

	Besides this ,  changes also include :

1. more information concern hpf directive is recorded in .dep file . 
   hpfattr which record the align or distribue information in symbol 
   entry once is created but forgot to record in dep . In this version ,
   I add this feature in readnodes/writenode.c in basicop. Vdumpdep is also
   adjust to display this new feature . Yan and Du , please pay attention
   to this.

2. correct the hpfsc 's erronously report errors on pivot.f90 .

3. correct 2 minor errors on transG which I have mentioned in last letters.

4. adjust Makefile.in  in some directories .

5. modified low_level.c in xsageop to solve the portability problem of head
   file stdarg.h

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Wed, 27 Nov 1996 09:25:06 +0800 (EAT)

On Tue, 26 Nov 1996, Guansong Zhang wrote:

> I don't understand this code well, let me check with you line by line, some are
> my questions, some are suggestions.
> 
> > PREFIX=$prefix ; EXEC_PREFIX=$exec_prefix
> > test "x$prefix" = xNONE && PREFIX=$ac_default_prefix
> > test "x$exec_prefix" = xNONE && EXEC_PREFIX='${PREFIX}'
> 
> When I first change the code in acconfig.h, I also meet this problem. Are you
> sure the $ac_default_perfix will be used in different versions of autoconf?
>

	I think they have no reason to change it . 

> Why you need an x in the test?

	in case exec_prefix is a null string .

> 
> > SRCDIR=`pwd`
> > LIBDIR=`eval echo $EXEC_PREFIX/lib`
> > test ! x`echo $LIBDIR |cut -f1 -d/` = x  &&  LIBDIR="$SRCDIR/$LIBDIR"
> 
> What does this part mean? Are you sure eval and cut are basic shell command? At
> least eval seems not. Why not LIBDIR=$(EXEC_PREFIX)/lib directly?
> 

	eval do is a basic shell command , use grep , you can find so many 
eval in configure itself. Only use LIBDIR=$(EXEC_PREFIX)/lib  , will get 
this result in some case :   ${prefix}/lib , where ${prefix} still is unknown
when compile intr_call.c . So I use eval to expand the prefix . 
	Still here , I considered the case when use prefix=. as relative
path, anyway I cannot found in autoconf manual that it prohibit the use
of this kind of path as prefix .

> Given the following code I think it is not nessesary to test to decide LIBDIR,
> just define it as $(EXEC_PREFIX)/lib is good enough, right?
> 
> > INTR_LIB=libhpf.sl
> > AC_SUBST(INTR_LIB)
> > AC_DEFINE_UNQUOTED(HPFSRCINTR_LIB,"$SRCDIR/src/hpfsc/$INTR_LIB")
> > AC_DEFINE_UNQUOTED(HPFLIBINTR_LIB,"$LIBDIR/$INTR_LIB")
> 
> I think there is no necessary let configure to substitute INTR_LIB, it will try
> to do so in each Makefile, just use libhpf.sl in Makefile of hpfsc is good
> enough.
> 

	I thought this would increase more flexibility . If you don't think
so , I can change . 

Zheng