Subject: Warning ! Re: updated 1.68

From: Zheng Gengbin <[email-masked]>
Date: Tue, 19 Nov 1996 17:38:48 +0800 (EAT)

Please note , in your updated 1.68 , link.c in hpfsc is not updated !!

	Now I will comment on your update:

On Mon, 18 Nov 1996, Guansong Zhang wrote:

> Based on 1.68 you sent here last week. We make the following update:
> 
> 1. configure.in was changed according to your 1.68, and I rearrange the order
> of thoes test, so you need to rm config.cache to reconfigure the system. Some
> make file was addjust a little.
>

	Do not move the checking of -l flag after the testint of 
whether yytext is pointer . Because when testing yytext , I will use the
result of whether lex support -l flag. Your change will let configure
make wrong decision .

> 2. in include dir, defnode.h was changed to define YYLMAX.
> 
> 3. in xsageop, the member function lastDeclaration was changed. I noticed
> Gengbin once changed low_level.c about this function. It seems the change is
> not complete. The main problem is that how to deal with CONTROL_END, if I
> understand your change correctly.
>

	I cannot find your change in this version , please check .
 
> If we check the node in tree link, not in queue link as coded previously, we
> can solve this problem better. You may check it to see if it is OK for transBD.
>
 
	I don't quite understand what you mean tree link and queue link ,
As I understand , you mean travel by thread or bob ?
 
> 4. in hpf2dep and hpfsc, change from your 1.68 is merged.
> 
> 5. in transG, new things added, we can deal simple print statements now.
> 
> Guansong
> 

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Thu, 21 Nov 1996 09:12:31 +0800 (EAT)

It seems that in this version , the problem in configure.in 
has not been corrected .

Zheng