Subject: Re: New vesion 1.56

From: Zheng Gengbing <[email-masked]>
Date: Wed, 29 May 1996 16:14:33 +0800 (EAT)

On Tue, 28 May 1996, Guansong Zhang wrote:

> On May 28, 10:06am, Zheng Gengbing wrote:
> > Subject: New vesion 1.56
> > Hi,
> >
> > 	everyone ,
> >
> > 	This new version 1.56 is mainly for testing the configuration .
> >
> > 	in this vesion ,
> > 1.  gcc is the first choice if present , otherwise cc is also ok.
> >
> > 2.  bison is prefered if present , otherwise yacc is ok.
> >
> > 3.  since the hpfparser.tab.h is different both in the number but also the
> > format of the file produced by yacc and bison , I rewrite the code to
> > generate  error.file in both case in Makefile.in .
> >
> > 4.  lex is forced even if flex is found , since we still not solve the
> > input & output problem.
> >
> > 5.  add in configure.in the checking of yytext , if yytext is defined as
> > unsigned char yytext[] , the IS_UNSIGNED_CHAR is defined in config.h .
> > In order to perform the checking , I add a conftest.l in config dir .
> >
> > 6.  Makefile.in are adjust accordingly .
> >
> >
> > So , now please check this package in whatever machine available to you ,
> > and give me your comments .
> >
> >
> >
> >
> >-- End of excerpt from Zheng Gengbing
> 
> With some minor changes, this package can be built on here:
> 
> rs6000-ibm-aix3.2.5
> mips-sgi-irix5.3
> sparc-sun-sunos4.1.1
> alpha-dec-osf3.0
> sparc-sun-solaris2.4
> 
> But some of the them still have segment fault problem when make check.
>

	I have noticed that , please debug them if you can.

> (Comparing with the results generated by ibm, the best come from sgi-irix5.3,
> while the worst is from sun-sunos4.1.1.)
> 
> The problem concerned with configuration are only two:
> 
> 1. yytext. non-POSIX standard lex do not support %array yytext, considering it
> is an illegal statement. (The test one char or unsigned char also will let
> solaris complain, I am not sure why.)
>

	I am trying other means .
 
> 2. strings.h or string.h. I think autoconf has already solved this problem, the
> AC_HEADER_STDC in configure.in was not used when strings.h or string.h is used
> under src/tool yet.
> 

	I have use AC_HEADER_STDC in hpfsc/ now .

> The next step we need things like VPATH to let it possible to check on
> different kind of machine at the same time.
>

	We seems have no gmake on my machine .
 
> I don't understand the following code in configure.in:
> 
> lex ./config/conftest.l 1>conftest.$1 2>conftest.$2
> mv  lex.yy.c  conftestlex.c
> AC_EGREP_CPP(unsigned.*yytext..;$,
>   [
>    #include "conftestlex.c"
>   ] , AC_DEFINE(IS_UNSIGNED_CHAR)  \
>       echo set yytext--unsigned char
>     , echo set yytext--char )
> 
> What are conftest.$1 and conftest.$2? How were they used?
> 

	They are used as redirection files. In fact conftest* will be removed 
automatically in configure .

> It seems not all machine can generate this conftestlex.c file. I don't know its
> usage.
> 
> And I also have a question about the regular expression you used, why you
> assume there are only two char after yytext and before ";"? A bug?
> 

	To autoconf , [ & ] have special use ,so I use '.' to replace them .
I find a solution now .

Zheng

---

From: Zheng Gengbing <[email-masked]>
Date: Wed, 29 May 1996 17:36:37 +0800 (EAT)

It turned out to be a bug of format_item_list in f90.y which caused
core dump in sun4(nova) . After some change , the running on sun is quite
well now.

	To my joy , after these change the result of hpf2dep on kestrel1 is 
also quite good now .But since the gcc of kestrel1 is of low version ,
which has no __builtin_va_start() , so the compilation of hpfsc failed .
This maybe also a configuration problem .

---

From: Zheng Gengbing <[email-masked]>
Date: Thu, 30 May 1996 09:01:34 +0800 (EAT)

Now you can fetch a new version 1.56 and do your change on it .
And please test the compilation and execution on your machine .

Zheng Gengbin

---

From: Zheng Gengbing <[email-masked]>
Date: Thu, 30 May 1996 16:51:19 +0800 (EAT)

In this new version 1.56 , I wrote a return(NAME) imediatly after
call to i=searchKey_m(name,FUNC_TAB_G,FUNC_TAB_LIMIT_G) , so unput() is 
jumped . 
	Since then , flex can also do a good job .

	To enable the configure to check the yytext feature , don't forget
to remove the comment in the line 53 , and comment the next line if you
decide to use the lexer found by configure instead of forcing to use lex 
as the compiler of hpflexer.l .

Zheng Gengbin