Subject: New version 1.69

From: Zheng Gengbin <[email-masked]>
Date: Thu, 28 Nov 1996 15:31:14 +0800 (EAT)

This is a new version 1.69 . The main changes are concentrate in
the xsageop lib , there I reduced from 22 header files to only 14 .
 in the include dir several header files are changed accordingly .

	Also dumpdep is updated to the new feature .

	This version is also for test and comments .

Zheng .

---

From: Zheng Gengbin <[email-masked]>
Date: Mon, 2 Dec 1996 08:29:32 +0800 (EAT)

On Sun, 1 Dec 1996, Guansong Zhang wrote:

> I need to add:
> 
> #define NO          0
> 
> In make_node.c in xsageop to compiler the lib.
> 

	I remember that I have changed the xsageop where NO is refered to NON . 
Donot define NO because you will find NO is already defined in 
hpfparser.tab.h  as a KEYWORD. In the new version , it should be ok. 

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Mon, 2 Dec 1996 08:35:29 +0800 (EAT)

On Sun, 1 Dec 1996, Guansong Zhang wrote:

> 
> On Nov 28, 10:15am, Zheng Gengbin wrote:
> >
> > 	Yes , I also feel the header file is totally a mess in xsageop .
> > there are 22 header files there :
> >
> > baseClasses.h           macro.h                 sageroot.h
> > compatible.h            sage++callgraph.h       sets.h
> > db.h                    sage++classhierarchy.h  typedef.h
> > defs.h                  sage++extern.h          version.h
> > ext_lib.h               sage++proto.h           vparse.h
> > extcxx_low.h            sage++user.h            vpc.h
> > f90.h                   sage.h
> > fromsage++.h            sagearch.h
> >
> > 	Among these files , some are the same (almost) as the header files
> > in include (like defs.h ,f90.h ,typedef.h) , some can be removed ,like
> > (sagearch.h , compatible.h,sageroot.h ,version.h ) , some seem can be merged
> > with some header files in unparse , like vparse.h .
> > 	I will first deal with the first issue of above . You can think about
> > the third .
> >
> 
> What do you mean by the third? vparse.h?
> 

	I mean the third condition above if we can think about merge some header
files in xsageop with those in unparse like db.h .

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Tue, 3 Dec 1996 09:44:11 +0800 (EAT)

On Mon, 2 Dec 1996, Guansong Zhang wrote:

> On Dec 2,  8:29am, Zheng Gengbin wrote:
> > Subject: Re: New version 1.69
> >-- End of excerpt from Zheng Gengbin
> 
> Are you still working on new version of xsageop? then you'd better work on this
> new version I am sending to you. Here I also need to change something, mainly
> in transG, we can deal with scalar assign now.
> 
> Another thing I changed is about compiler flags, since not all compiler accept
> -g and -O at same time. But I am not sure if this change conflict with other
> things, please check it. Or we may further improve it to control compiling and
> target speed. (I am not sure about the flags used by g++, and don't know why
> you use -O at present time, it may slow the compiling speed of the project. So
> I just configure it as you did.)
> 

	In fact , configure will automatically decide which flag to use .We
need not worry about that . But I also feel -O greatly slow down the 
compiling speed . Your change may have some defect also , since on some 
machine , gcc cannot support -g flag though it only give a warning . 
Anyway I will think your change is temperary in the version between us 
developers and should not be included in the release version . 

> I think you foget to rm conftest.l somewhere in this new configure.in, please
> check it.
> 

	Now I cache the result of the checking of LLFLAG , it should be
ok now.

> Guansong
> 
> P.S.
> 
> HIT, please note the new verson, and I put it on pact518.hit.edu.cn, please
> update your work.
> 
> 
> 

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Tue, 3 Dec 1996 09:45:34 +0800 (EAT)

On Mon, 2 Dec 1996, Guansong Zhang wrote:

> On Dec 2,  8:35am, Zheng Gengbin wrote:
> I further check this, I think the file need to be pay attention to is macro.h,
> there also a copy of this file in unparse. It also includes other files, which
> should be seperate out if we put it to include dir.
> 
> I am not sure if you are going to work on it. Please let me know in case we
> duplicated our work.
> 

	You can work on this now , my work won't be duplicated with you.

Zheng