Subject: Re: config.h

From: Zheng Gengbing <[email-masked]>
Date: Sun, 12 May 1996 15:15:59 +0800 (EAT)

On Fri, 10 May 1996, Guansong Zhang wrote:

> >
> > 	I  don't think your configuration is very good .
> >
> > 	1. Makefile in root still  contain  directory dependent information
> > 	  such as  bin , lib , include . Make uninstall will fail if
> > 	  user change their prefix.
> 
> I don't understand this, why?
> 
> Actually, the present method install unistall from the dir configure decided.
> Though this is not shown in top dir Makefile.
> 

	Since these lines in Makefile:
        if [ -d bin ] ; then rm -r -f bin ; fi
        if [ -d include ] ; then rm -r -f include ; fi
        if [ -d lib ] ; then rm -r -f lib; fi

	if user change the prefix ( install dir ) , make disclean can not
work well.

> I will write another letter to explain my principle of writing Makefile to make
> this more clear.
> 
> >
> >
> > 	2. need not move config.h in configure.in ,
> > 	  just use
> > 		AC_CONFIG_HEADER(./src/include/config.h)
> > 	  will do the job .
> >
> > 	 but I do't think put config.h with other include files is
> > 		a good idea.
> >
> 
> This is really something I am not sure of, So I use the clear Move in the
> configue. The problem concerned with this is, whether config.h should be
> installed.
> 
> Any way, the good poind of the method in 1.49 is that one -I flag can be saved
> in Makefile. It is also some kind of clearness, right?
> 
> Another point,
> 
> AC_CONFIG_HEADER(./config/config.h) will let autoheader creat a config.h.in in
> config dir.
> 
> I want to change it to this:
> 
> AC_CONFIG_HEADER(./config.h), so the config.h.in and config.h will be both in
> topdir, and then, we can decide, when configure, whether move config.h to
> src/include. ( I think we need consider this carefully.)
>

	I don't know what's that for .

> In this way the config dir will be quite clean: only three file from autoconf
> package.
> 

	I don't know the necessarity to keep the config dir clean . 

***************************************************************************
*     Zheng Gengbin                 *                                     *
*                                   *                                     *
*  Dept. of Computer Science        *  Phone:  86-10-2585088              *
*         & Technology              *  Email:                             *
*                                   *      [email-masked]   *
*  Peking University P.R.China      *  Mail:                              *
*                                   *      Room 1077 ,Building 47,        *
*                                   *      Peking University, P.R.China   *
***************************************************************************

---

From: Zheng Gengbing <[email-masked]>
Date: Sun, 12 May 1996 15:15:59 +0800 (EAT)