Subject: Version 1.52

From: Zheng Gengbing <[email-masked]>
Date: Tue, 14 May 1996 20:45:26 +0800 (EAT)

Hi,

	Here , we have version 1.52 .

	In this new version , we fixed these bug mentioned before :

	1.   if (.not. associated (a) ) exit .
	     I deleted ASSOCIATED from keywords.h ,and delete associated_stmt
		in f90.y

	2.   print "aaa",x
	     now , it is ok.

	3.   merge the modification from Zheng Qiang on if stmt.

	The main change of these version is in hpfsc part . Now the test 
result on our machine is quite good , except NAG . 

	I compressed the whole project *52 in ~/pact .

***************************************************************************
*     Zheng Gengbin                 *                                     *
*                                   *                                     *
*  Dept. of Computer Science        *  Phone:  86-10-2585088              *
*         & Technology              *  Email:                             *
*                                   *      [email-masked]   *
*  Peking University P.R.China      *  Mail:                              *
*                                   *      Room 1077 ,Building 47,        *
*                                   *      Peking University, P.R.China   *
***************************************************************************

---

From: Zheng Gengbing <[email-masked]>
Date: Wed, 15 May 1996 17:01:03 +0800 (EAT)

On Tue, 14 May 1996, Guansong Zhang wrote:

> On May 14,  8:45pm, Zheng Gengbing wrote:
> > Subject: Version 1.52
> >
> > Hi,
> >
> This one is ok. (I take the method used by pku right now )
> 
> 
> >
> > 	2.   print "aaa",x
> > 	     now , it is ok.
> 
> Well, the print statement is ok, but the format statement still have this
> problem. you can look the dumpdep result for program in test90 with format
> statement.
>

	Now , the format is also ok .

> This is ok now.
> For test90, there are still several semantics error, I am not sure about these.
>

	Now , I am going to explain the semantic error found in test90:
from now , we have only 1 files report errors :

	* history.f90:

hpfsc: line 16 error 584:label is undefined or invalid used 
	see line 16:

16            print 100, number
17            !zgs 100         format ( / ' ', 'Number ', i2.2 / )

	since you comment line 17 , now the label 100 is undefined , so report
error .

	The new version 1.52 is ready now . You can fetch it .
	In order to produce error.file easily , I add a error.file in Makefile
of hpf2dep.