Subject: Re: new 1.49

From: Zheng Gengbing <[email-masked]>
Date: Fri, 10 May 1996 15:22:30 +0800 (EAT)

On Thu, 9 May 1996, Guansong Zhang wrote:

> I am sending back a new 1.49
> 
> Comparing yesterday's work:
> 
> 0. hpf2dep and hpfcc were not touched except hpfcc was renamed as hpfsc
> 
> 1. The Makefile.in was addjusted, so you can make install. Now I will consider
> All the Makefile.in relative stable, if you change them, make a notice to
> others.
>

	I  don't think your configuration is very good .

	1. Makefile in root still  contain  directory dependent information
	  such as  bin , lib , include . Make uninstall will fail if
	  user change their prefix.

	2. need not move config.h in configure.in ,
	  just use 
		AC_CONFIG_HEADER(./src/include/config.h)
	  will do the job .
	
	 but I do't think put config.h with other include files is
		a good idea.

***************************************************************************
*     Zheng Gengbin                 *                                     *
*                                   *                                     *
*  Dept. of Computer Science        *  Phone:  86-10-2585088              *
*         & Technology              *  Email:                             *
*                                   *      [email-masked]   *
*  Peking University P.R.China      *  Mail:                              *
*                                   *      Room 1077 ,Building 47,        *
*                                   *      Peking University, P.R.China   *
***************************************************************************

---

From: Zheng Gengbing <[email-masked]>
Date: Fri, 10 May 1996 17:34:05 +0800 (EAT)

Hi,

	Now , you can find Version 1.50 in  ~/pact .

	In this version :

	1. hpfsc can pass all sample files of testhp;

	2. testsuite is orgnized , invalid dir contains the sample files ,
		I create 3 subdir , but I have no time to maintain the
	        Makefiles.

	3. add a field to symbol table , so include dir is changed
	   and basicop is changed accordingly.

	A lot of bug mentioned in your letter in these days is debuged out,
you can test them .

	The name of the file is  ' hpfFrontEnd-1.50.tar.gz '

Zheng Gengbin