Subject: Re: hpfsc error

From: Yan Mi <[email-masked]>
Date: Tue, 17 Dec 1996 09:09:56 +0800 (EAT)

IN ymio.c, line 383, i got the io_control_list and output_list of 
write_stat  according to its definition in bif.h ,  write_stat. And in bif.h
the ll1 is format,ll2 is expr_list,ll3 is control_list. So i don't understand
why line 4854 of f90.y is  " $$ = makeWriteBfnd($$,$5,$3); ". I think it 
should be " $$ = makeWriteBfnd($$,LLNULL,$5,$3); "
	And it is the same with read_stat. In line 4655-- 4675 of f90.y, i 
think we should reorder the sequence of ll2 and ll3 because in bif.h, ll2 
is input_item_list,ll3 is io_control_list.
	If you change f90.y to make it consistent with the definition of
bif.h . I need modify nothing in ymio.c. You may read line 383--384  and 
line 258--259 of ymio.c to see this.   

On Sun, 15 Dec 1996, Guansong Zhang wrote:

> Hi, Yan Mi:
> 
> Please also not that the f90.y need to make the following change about
> write_statement.
> 
> write_stmt
>     :  WRITE LEFTBRACKET io_control_spec_list
>        RIGHTBRACKET output_item_list in_prog {
>           $$ = makeBfnd(fi,WRITE_STAT);
>           $$ = makeWriteBfnd($$,$5,$3); /*xli. 12/13/96 */
>           }
>     |  WRITE LEFTBRACKET io_control_spec_list
>        RIGHTBRACKET in_prog {
>           $$ = makeBfnd(fi,WRITE_STAT);
>           $$ = makeWriteBfnd($$,LLNULL,$3);   /*xli. 12/13/96*/
>           }
>     ;
> ========================
> 
> I changed unparse accordingly, but hpfsc need to be addjusted to new one.
> 
> 
> On Dec 14,  9:29am, Zheng Gengbin wrote:
> > Subject: Re: hpfsc error
> >
> > 	I just checked this . It is ok now .
> >
> > 	Yan mi , please check if I my change is correct in ymio.c line 141 .
> >
> > Zheng.
> >
> > On Wed, 11 Dec 1996, Guansong Zhang wrote:
> >
> > > Please check this:
> > >
> > > It seems hpfsc will complain about the following program, which can be
> parsed
> > > by xlf smoothly.
> > >
> > > Guansong
> > >
> > > --------------------------------
> > >
> > >       PROGRAM LAPLACE
> > >       INTEGER N,Nsteps
> > >       PARAMETER(N=16)
> > >       PARAMETER(Nsteps = 100)
> > >       INTEGER i,j,k
> > >       REAL A(N,N),B(N,N),C(N,N),D(N,N),tolerence,error
> > >       INTEGER niter,nicycle,x,y
> > >       INTEGER toler(2)
> > > !HPF$ PROCESSORS PROC(2,2)
> > > !HPF$ TEMPLATE TEMP(N,N)
> > >
> > > !HPF$ DISTRIBUTE TEMP(BLOCK,BLOCK) ONTO PROC
> > >
> > > !HPF$ ALIGN A(i,j) with TEMP(i,j)
> > > !HPF$ ALIGN B(i,j) with TEMP(i,j)
> > > !HPF$ ALIGN C(i,j) with TEMP(i,j)
> > >
> > > !      B = A
> > > !      C = A
> > >       print *, 'Final grid looks like'
> > >       DO I= 1, N
> > >         write (UNIT=*, FMT=101) (A(I,J),J=1,N)
> > >       END DO
> > >
> > > 101   FORMAT(12F9.3)
> > >       END
> > >
> >
> > ***************************************************************************
> > *     Zheng Gengbin                 *                                     *
> > *                                   *                                     *
> > *  Dept. of Computer Science        *  Phone:  86-10-2585088              *
> > *         & Technology              *  Email:                             *
> > *                                   *      [email-masked]   *
> > *  Peking University P.R.China      *  Mail:                              *
> > *                                   *      Room 1077 ,Building 47,        *
> > *                                   *      Peking University, P.R.China   *
> > ***************************************************************************
> >
> >-- End of excerpt from Zheng Gengbin
> 
> 
>

---

From: Zheng Gengbin <[email-masked]>
Date: Tue, 17 Dec 1996 09:42:58 +0800 (EAT)

> line 258--259 of ymio.c to see this.   

	I agree with you . The ll_ptr2 and ll_ptr3 should be created according
to the definition in bif.h .
 	In fact , I have already changed f90.y like this . But I have not 
touched unparse.

Zheng