Subject: Re: New version .

From: Zheng Gengbing <[email-masked]>
Date: Wed, 8 May 1996 09:53:00 +0800 (EAT)

On Tue, 7 May 1996, Guansong Zhang wrote:

> On May 6,  7:47pm, Zheng Gengbing wrote:
> > Subject: New version .
> >
> > ++++++++++++++++++  testhp  +++++++++++++++
> >
> > 	hpf2dep : pass all without any error .
> > 	dumpdep : ok
> > 	hpfcc   : core dump
> > 			evolve+ , ivp+ , t2+ , t2_dummy+
> > 			( these core dump are all concerned with io part ,
> > 				which is now in development )
> > 	unparse : all passed
> >
> >
> >
> >
> >
> >-- End of excerpt from Zheng Gengbing
> 
> 
> Here again we have machine problem, they all memory fault on my machine, I have
> no time to check it today.  Make sure they are ok on your machine first, I will
> dbx it tommorow.
> 
> And on my machine, after hpfcc re write timer+.dep, it will cause a memory
> fault to dumpdep.
> 

	I also found this problem in Linux , I will check them .

***************************************************************************
*     Zheng Gengbin                 *                                     *
*                                   *                                     *
*  Dept. of Computer Science        *  Phone:  86-10-2585088              *
*         & Technology              *  Email:                             *
*                                   *      [email-masked]   *
*  Peking University P.R.China      *  Mail:                              *
*                                   *      Room 1077 ,Building 47,        *
*                                   *      Peking University, P.R.China   *
***************************************************************************

---

From: Zheng Gengbing <[email-masked]>
Date: Wed, 8 May 1996 19:03:29 +0800 (EAT)

Hi,

	We have version 1.49 ready now.

	In this version , pointer error of hpfcc debugged out .

	The test result is:

++++  test?.f90
	
		hpf2dep :   all passed without error ;
		hpfcc   :   all passed , test1 , testh have report errors .
		dumpdep :   all passed
		unparse :   all passed 

+++ test90

		hpf2dep :  all passed without error
		hpfcc   :  all passed with some errors .
		dumpdep :  all passed
		unparse :  ok

+++ testhp

		hpf2dep : all passed without error
		hpfcc   : all passed , only ivp+.f90 report errors .
		dumpdep : all passed
		unparse : all passed 

ivp+ have these statement :

	r = sqrt( xx*xx + yy*yy + zz*zz )

and xx , yy , zz is defined as array ,
but in my opinon sqrt do not support array type , so ivp+ cannot pass .

	There is a bug I found  in hpf2dep:

        associated stmt ,  I suspect this is realy a action stmt ?
	   in fact I think it is a intrinsic function .
	   try:
	     if ( .not. associated(a) )  exit .

	   you will find ASSOCIATE_STAT bfnd created !