Subject: Re: Problems with Multi-platform

From: Zheng Gengbin <[email-masked]>
Date: Fri, 22 Nov 1996 14:19:18 +0800 (EAT)

Here is my comments ,

On Thu, 21 Nov 1996, Xinying Li wrote:

> 
> After I tested the current version on five platforms of six machines, I 
> found the following problems to be concerned:
>  
> 1.
> 
> On risc6000(merlini, afognak),alpha(kestrel),irix(sandman), 
> 
> test1.dep.sem   189
> testh.dep.sem   332     
> pivot.dep.sem   137
> 
> maybe they should be 0.
>

	I believe there do have some semantic errors in these 3 files.
 
> 2.
> 
> On sunOS (nova.npac)
> 
> *.sem in any directory are 0.
> 

	I have tested this , I found no difference with the first .
	Note , I use 
	setenv LEX lex ; ./configure 
	to compile the front End . otherwise , the frontend cannot be
	compiled .

> 3.
> 
> On solaris -- naos.npac , some core dumped occur, (the following are 
> parts of them)
> 
> ...Second pass compiling  tour.dep  
> Preprocessing ...
> Preprocessing done. 
> Segmentation Fault - core dumped
> 
> ...Second pass compiling  test1.dep
> Preprocessing ...
> Preprocessing done. 
> Segmentation Fault - core dumped
> 
> ...Second pass compiling  exec_test1.dep
> Preprocessing ...
> Preprocessing done. 
> Segmentation Fault - core dumped
> 
> 

	I will check this later .

---

From: Zheng Gengbin <[email-masked]>
Date: Wed, 4 Dec 1996 17:09:13 +0800 (EAT)

> Segmentation Fault - core dumped

	I have checked this , it should be ok . Please note , donot hpfsc
a same dep for more than once ,this sometimes may cause core dump . 

	Now I will describe the portabilty of the frontEnd below :

	These are the configure step which can successfully compiled the 
frontEnd now:

1. noas

	setenv LEX lex ;  configure

2. kestrel1

	setenv CC cc ; setenv LEX lex ; configure

	// gcc cannot compile low_level.c , the reason is the variable 
arguments list.

3. nova

	setenv LEX lex ; configure

	// cc cannot compile xsageop because of the c compiler is non-ansi ,
	and cannot accept the variable argument list in low_level.c . This
	machine seems have no gcc .

4. mel

	configure

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Wed, 4 Dec 1996 17:23:51 +0800 (EAT)

A new version 1.70 is ready . This version include these features:

	1.  hpf2dep can preprocess the include statement .

	2.  adjust all Makefile so that the frontend can be compiled 
		using VPATH feature . THis version has been experimented
		on mel , kestrel , naos and nova .

Zheng