Subject: problems of transG

From: Du_Zhi_hui <[email-masked]>
Date: Thu, 7 Nov 1996 09:12:42 +0800 (EAT)

Hi ,Zhang guanshong:
	when we use transG trying to get node program of our test file ,the follwoing errors often appear:

$ ../transG/transG test2_t.dep
Not touched statement in analyse on line 9
Not touched statement in analyse on line 10
Bus error(coredump)
 ****** test2_t.dep is the transformation resoult of trans.

$ ../transG/transG test2f.dep
Not touched statement in analyse on line 5
Not touched statement in analyse on line 6
Bus error(coredump)
 ****** test2f.dep is the result of unparse test2_t.dep and then compiling it to dep file.

Could you tell me what is wrong with it?

Du Zhihui.

---

From: Du_Zhi_hui <[email-masked]>
Date: Fri, 8 Nov 1996 16:52:44 +0800 (EAT)

Zhang Guansong:
	Thanks for give us some hints of the problems.We have tested all 
the test files passed by transBD, except test6.f,stest2.f, no one 
can be passed by transG,the error is "Bus error(coredump)".even test6.f also 
has following error:

Not touched statement in analyse on line 4
Not touched expression in FORALL statement!
Not touched statement in analyse on line 10

-----------------
Not touched statement in transform_1 on line 4
none
  0  0  0  0  0  0  0  0  0  0
Not touched statement in transform_1 on line 10
___Your HPF program's dep_file have been written !___

stest2.f is correct.

the test files are located at directory:

	pact/NPAC/*2/src/transBD

the test files are test1.f-test6.f ,stest1.f-stest9.f,I also package the 
test file with this letter.

yanmi has find some more and detail problems of 
transG.I think that 
transG you gave us perhaps have changed these days,so I want a new version 
of transG.Based on our test, we only can use transG to generate very 
simple node program.So I want some test files you have passed ,by 
comparing your test files and ours,I think we can find some useful 
information.
	You said that some test files can not be transformed directely by 
transG, Would you please give us test files can not passed directely by 
transG? from these test files we can find the problems of transBD .

Du Zhihui

 On Thu, 7 Nov 1996, Guansong Zhang wrote:

> First about the "not touched statement", it is possible a return statement
> which transG can not deal at present time. So delete unnecessary return
> statement.

########################################################################
> ****** I find the not touched statement is HPF distribute statement and 
enddo statement of transformed result of test6.f.
########################################################################

> tell me what exact source code you met problem please.

########################################################################
> ****** you can get the exact source code from what I sent you with this 
letter or from the directory I tell you forward .
########################################################################

> By the way, you can not use transG to handle the .dep file generated by transBD
> directly. I think that transBD do not respect some rules in constructing AST. I
> failed on my machine to do so. You need first unparse the result from transBC
> and then parse it, and give transG a new .dep.

#######################################################################
> ******   So I want to get the test files you use,I will find which 
rules transBD do not respect in constructing AST.
#######################################################################

> Guansong