Subject: about "trans0"

From: Shi Lixia <[email-masked]>
Date: Wed, 7 May 1997 10:40:51 +0900 (TAIDT)

I don't understand what the next program code means.
  
         if (rhsref->getCommunication()==NONE) {
           if (forall_carry_dependent(lhsref, rhsref)) {
                  rhsref->setCommunication(REMAP);
                  return;
             }
      }
     
      it is in detect_communication of reference.C.
      that is to say, if rhs doesn't communicate with lhs, then
if there is dependenceklkerrdfd between lhs and rhs , then communicate to 
eliminate dependence.
      it is obvious that forall_carry_dependent() is detecting dependence.
      You say that there is not dependence. Can't it be contradictory?
       can I understand so?

shi li xia

---

From: Shi Lixia <[email-masked]>
Date: Wed, 7 May 1997 20:58:29 +0900 (TAIDT)

On Tue, 6 May 1997, Guansong Zhang wrote:

> On May 7, 10:40am, Shi Lixia wrote:
> > Subject: about "trans0"
> >
> The following is what I wrote:
> 
> On May 6, 10:04am, Guansong Zhang wrote:
> > Subject: Re: forall
> > On May 6,  9:06am, Shi Lixia wrote:
> > > Subject: forall
> > >
> > >
> > >      You are responsible for forall statement in trans0. It is clear that
> > > you know forall's semantics. Is there data dependence in forall? Or its
> > > dependence has been eliminated?
> > >      When you are transforming forall, do you detect data dependence?
> > >      Please give me a clear answer.
> > >
> > > shi li xia
> > >
> > >
> >
> > In forall statement, you do not consider data dependence, (if there is, very
> > little), you can read FORALL statement definition for more on this.
> >
> > Guansong
> >-- End of excerpt from Guansong Zhang
> 
> 
> When I said "very little", that means there is a case some thing should be
> done.
> 
> For example
> 
> forall (i=...) a(i)=a(i-1)
> 
> The loop carried dependence (I used the term of do loop) need to be take care
> of. But we don't add dependence analysis in libxsageop.a yet. So a "short-cut"
> way is used.
> 
> 
> Guansong
> 
  
  I don't understand what you said. What does "short-cut" way 
mean?  Isn't someone analyzing dependence?  Because Prof. Ding
wants to let me analyze dependence. I need latest information
about this.
  I'd welcome any suggestion.             

shi li xia