Subject: Re: sage lib, my current version

From: Zheng Gengbin <[email-masked]>
Date: Fri, 20 Sep 1996 15:41:07 +0800 (EAT)

On Thu, 19 Sep 1996, Guansong Zhang wrote:

> On Sep 20,  9:53am, Zheng Gengbin wrote:
> > Subject: Re: sage lib, my current version
> >
> > Hi,
> >
> > 	When I compiled a simple example with libxsage.a , I found these:
> > /bin/ld: Unsatisfied symbols:
> >    cunparse_blck (code)
> >    cunparse_type (code)
> >    funparse_blck (code)
> >    funparse_type (code)
> >
> >
> > and these functions are defined in file db_unp_vpc.c . Why not copy it to
> > dir xsageop ?
> >
> >
> > Zheng .
> >-- End of excerpt from Zheng Gengbin
> 
> I don't think you should have problem like this. In the verson I sent to you,
> the db_unp_vpc.c is not necessary. You must mistake some file. Please check
> again.
>

	I cannot believe you have compiled any program when linking 
libxsage.a . When I make in the example you send to me , the problem also 
there .
	So I decide to add those 4 empty functions at the end of the db.c ,
just like 6 functions appeared at the end of that file . Then I can 
successfully compiled the addstuff now .

	But when I ran addstuff , it core dumped at statement :
afuncall->addArg(c2.copy());

	After examined the SgCallStmt::addArg(SgExpression &arg) , I found
this function has been modified by you . And there is a small bug in there.
After I modified a little , now addstuff can successfully run now .

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Sat, 21 Sep 1996 08:54:53 +0800 (EAT)

On Fri, 20 Sep 1996, Guansong Zhang wrote:

> I think maybe I know the reason. In db.c, those functions were declared. At the
> end of db.c you can also see some dummy definitions added. I may forget add
> those too. And xlC on RS6000 did not complain. You can add them. Maybe that is
> better than bring the db_unp*.c back.
> 
> 

	Yes , you are right. That's what I did yesterday . I added those 
functions and the problem solved .

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Mon, 23 Sep 1996 10:15:35 +0800 (EAT)

On Thu, 19 Sep 1996, Guansong Zhang wrote:

> It occured to me that if I use attach, uuencode may not necessary at all! This
> time two .tar.gz are attached!
> 
> Guansong
> 

	I have received the two .tar.gz and installed them . But I cannot
find any difference from the previous version you sent last week .

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Mon, 23 Sep 1996 10:52:01 +0800 (EAT)

On Sun, 22 Sep 1996, Guansong Zhang wrote:

> Here is something I just got, maybe useful to your work.
> 
> Those maping functions (I remember that they were in attribute.C when I
> seperate this file from the main file.) play a role as the layer between sage
> lib function and low_level c functions.
> 
> So maybe it will more clear to seperate them from attribute.C file.
> 
> Guansong
> 

	I have read those functions . And I think I have already learned how
they are mapped .

Zheng