Subject: Re: !!! Re: your mail

From: Zheng Gengbin <[email-masked]>
Date: Wed, 30 Oct 1996 10:03:43 +0800 (EAT)

Since thereis a bug in io-implied-do you moddifieddd , the AST to
hpfsc is abnormal .
	I have correcte8~d this and sent mail to you both a few days ago.

On Tue, 29 Oct 1996, Xinying Li wrote:

> 
> I just find many these errors in testing examples and semantics. I 
> haven't see them before.And I don't know why.
> 
> PKU:
> I'd like to know your result of testing two_body.f and orr_somm.f .
> 
> Xinying
> 
> On Mon, 28 Oct 1996, Guansong Zhang wrote:
> 
> > What does this mean in 1.65:
> > 
> > ...Second pass compiling  io_test3.dep
> > Preprocessing ...
> > Preprocessing done. 
> > here wrong llnd type:312
> > ___Your HPF program's dep_file have been written !___
> > 
> > Do you tell this to PKU?
> > 
> > Guansong
> > 
> > 
> > 
> 

***************************************************************************
*     Zheng Gengbin                 *                                     *
*                                   *                                     *
*  Dept. of Computer Science        *  Phone:  86-10-2585088              *
*         & Technology              *  Email:                             *
*                                   *      [email-masked]   *
*  Peking University P.R.China      *  Mail:                              *
*                                   *      Room 1077 ,Building 47,        *
*                                   *      Peking University, P.R.China   *
***************************************************************************

---

From: Zheng Gengbin <[email-masked]>
Date: Thu, 31 Oct 1996 09:36:57 +0800 (EAT)

This is the test result of nagtest of my version (I have corrected
the bug of the io_implied_do ):

two_body.f:
	no semnatic error .

orr_somm.f:
	2 errors:
hpfsc: line 3336 error 598:Cannot find the proper intrinsic procedure call 'maxv
al'.
hpfsc: line 3336 error 144:Scalar logic expression expected in if statement .

line 3336:
if (maxval(abs(y_now(:))) > 1.0e+10_wp .or. t_now == t_end) exit

	It turned out to be that abs(y_now(:)) failed to return a array type
when the argument is complex . Now I have corrected this .

Zheng
	
On Tue, 29 Oct 1996, Guansong Zhang wrote:

> Attached nagtest files: