Subject: New version 1.71

From: Zheng Gengbin <[email-masked]>
Date: Sat, 21 Dec 1996 10:37:48 +0800 (EAT)

Now the new version 1.71 is ready . This version solved these problems:

	1. Read , write statement is defined more consistent . The change as
	   I think is the same as you did . Also unparse.def is 
	   changed . 

	2. remove the use of the f90.h in unparse , defnodes.h is used instead.
		
	3. remove 2 bugs in hpfsc:
	   (1)  As Prof Li 's discovery , hpfsc changed the type of the template
		to float type which is wrong . 
	   (2)  As Zhang Guangsong's discovery , hpfsc wrongly reports error 
		of the format in write_statmet .

	4. the attribute bits is reorgnized in defnodes.h so that they are more
		readable .

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Tue, 24 Dec 1996 09:23:44 +0800 (EAT)

On Mon, 23 Dec 1996, Guansong Zhang wrote:

> Due to the network failure, I just got the 1.71.
> 
> It seems everything is fine, exept the Makefile.in in transBD and transG. It
> looks like they were changed back to the old ones? If you have some reason
> please let me know. I hope it is a mistake by file copy.
> 

	Maybe it is a mistake , I remembered I just intend to add the file
dependency such as hf.o: hf.C  . At the version before , hf.C seems not
present .

Zheng

---

From: Zheng Gengbin <[email-masked]>
Date: Wed, 25 Dec 1996 09:14:41 +0800 (EAT)

On Tue, 24 Dec 1996, Guansong Zhang wrote:

> On Dec 24,  9:23am, Zheng Gengbin wrote:
> > Subject: Re: New version 1.71
> >-- End of excerpt from Zheng Gengbin
> 
> .C.o will make hf.o depend on hf.C
> 

	I found on mel , this default rule will not take effect .

Zheng